PDA

View Full Version : 12" iBook G4 - battery charges but laptop won't power on




rascal77
Jun 8, 2009, 08:58 PM
Hey all - I have a 12' iBook G4 (1.33 ghz) that took a tumble and the power connector snapped off inside of it. I took it apart, popped out the broken bit from the dc-in board, and used it until the battery drained. It worked fine until then.

I bought a new power cord, but it failed to charge the battery, and after searching through countless forums, I figured the problem was the dc-in board. I bought a replacement, and just installed it. Now, the battery indicator lights (the four green ones) are showing that it's charging up. It's on three right now. But the computer still won't power on. No fan noise, no other lights. I tried the PMU reset, but nothing. It's weird.

Any thoughts? Thanks.



Reflow
Jun 8, 2009, 09:38 PM
Did you reset the pram? Sometimes that works...

rascal77
Jun 8, 2009, 09:50 PM
Thanks for replying.

I looked that up, but I'd need to power on the computer first, and that's just not happening. The battery is charged, judging by the indicator lights on it, but that doesn't seem to do anything. The power button isn't even lit up. I tried removing the battery and powering it on with just the power cord attached, but no dice. I am confused.

rascal77
Jun 9, 2009, 06:04 PM
Do you think it might have something to do with the power switch? I had to remove the casing on the keyboard side to pop out the broken piece. The bit where the power switch connects to the motherboard is attached to that casing. Is it possible that it came loose? It didn't come off, but I'm just trying to narrow down some possibilities here.

toolbox
Jun 9, 2009, 06:20 PM
you said in your previous post that it snapped something on the DC board? that is BAD. This is why your laptop is not getting power because the circut is broken. You going to need to take this to a Apple store and have them look at it. Your possibly going to be up for a new motherboard because the dc boards are a physical component i believe.

i.shaun
Jun 9, 2009, 06:58 PM
Not so sure about laptops. . because of the whole battery thing, but you could attempt to Reset the SMC (http://support.apple.com/kb/HT1806)

edit: PMU is probably the same thing. . you said you did that so I guess that option is out. .



What about removing RAM, re-installing it, and trying another outlet? worked for my intel iMac.

BlueRevolution
Jun 9, 2009, 07:00 PM
Actually, the DC-in board is separate and fairly inexpensive (http://www.ifixit.com/iBook-Parts/iBook-G4-12-Inch-DC-In-Board/IF183-030). iFixit doesn't have any guides for the 1.33 MHz model, but it's probably similar to the previous models (http://www.ifixit.com/Guide/Repair/iBook-G4-12-Inch-800-MHz-1-2-GHz-DC-In-Board/160/1).