PDA

View Full Version : What are your plans for porting your apps to 64-bit?




foidulus
Jun 11, 2009, 05:22 PM
Well now that 64-bit seems to be the premier feature of Snow Leopard, I was just curious to see what plans the devs here have for porting their apps to 64-bit.

Where I work we are a bit odd, we use ADA and lots of Java, so the 64-bit porting has been interesting.

The ADA was ported from PPC code and was a lot harder to port than we thought, but we are now finally rid of all PPC code. The Java was pretty easy, for the most part we just had to flip a switch and do some performance testing. However, there was one hurdle we had to cross, finding a 64-bit replacement for QTJava which Apple is letting die a slow, painful death(rumor is that it will be deprecated in Snow Leopard, at any rate it's 32-bit only in Leopard). Ultimately our app was simple enough that a few wrappers around QTKit did the trick, and now we are ready to distribute our 64-bit stuff out to the users.

What plans have other devs made to jump to 64-bit? Is anyone just eschewing it altogether(There are a ton of drawbacks, esp. on memory-constrained systems).



Catfish_Man
Jun 11, 2009, 07:31 PM
I'm working on it for Adium. Converting the main codebase was mostly just a lot of easy-but-tedious manual labor.

There were a few tricky bits there though:

Global keyboard shortcuts had to move from the KL* APIs to TIL* APIs; sadly this means that 10.4 and earlier keyboard layouts cause crashes.

Sound had to move to NSSound; sadly, NSSound API we needed to do this was only added in Leopard, so no 10.4 support there either.

(probably some others I'm forgetting now)

Right now I'm working on our dependencies. There's a bizarre crash in 64 bit PSMTabBarControl that I don't understand yet, and libiconv is missing a few symbols in 64 bit.

kainjow
Jun 11, 2009, 08:25 PM
Sound had to move to NSSound; sadly, NSSound API we needed to do this was only added in Leopard, so no 10.4 support there either.

Just curious... What were you using before? Couldn't QTKit have done what you needed for 10.4+ support?

Catfish_Man
Jun 11, 2009, 10:17 PM
Just curious... What were you using before? Couldn't QTKit have done what you needed for 10.4+ support?

http://hg.adium.im/adium/rev/3063c2f304a0