PDA

View Full Version : Add RAM onMyOwn?


Mr. Monsieur
May 14, 2004, 07:27 PM
Just got 512 MB of extra RAM from crucial and I went to put it into my new iBook...unfortunately Apple forgot to mention in their users guide that in order to get the plate off between the AE card and the RAM slot you need to have a set of professional clockworker screwdrivers! I was quite annoyed, to say the least. I have a set I use for tightening my glasses, etc., but those screws are ridiculously small! Sorry...just had to vent...here's the question (I should have asked it before I tried to put in the RAM!) Now that I failed once, I'm wondering if I was foolish to try in the first place--that is to say, is it really as simple as some people say it is (and as safe?) I'm tempted to go have someone do it for me (though I'd rather gain the experience myself!)...

dvdh
May 14, 2004, 08:46 PM
Installing ram on Ibooks (although my experience was with a G3) is not that big an ordeal.

On the apple website you will find this:

http://www.apple.com/support/ibook/doityourself/

If you follow that, there isn't too much chance of going wrong.

dbirider
May 14, 2004, 09:18 PM
Just go to a hardware store like homedepot and get a size 00 screwdriver for about 2$. I installed ram on my powerbook and it was really easy. just take out the battery, unscre the screws and shove the ram in. I think it would be a bad idea if apple included tools to take the machine apart with a purchace. It would sorta ruin there being simple image.

Mr. Monsieur
May 20, 2004, 12:14 AM
Thanks a lot, dvdh! I'm still quite annoyed that Apple didn't refer to the website in the owner's manual that comes with the ibook! From the manual, one gets the idea that it contains all the needed info...which it certainly does not! I continue to be enamoured with my ibook, however...: :) :

Coolvirus007
May 20, 2004, 08:55 AM
I tried opening the memory compartment on my pb but the screws wont budge. I think they done that so you would go to apple to get your ram replaced before you worn out the screws. quite angry at the moment: one powerbook...1 gb of ram.... only 512mb in the comp...CAN'T GET IT OPENNNN!!!