PDA

View Full Version : Need help installing airport extreme card in G3 iBook


dansuz1
May 14, 2004, 09:20 PM
I'm trying to install an airport extreme card in my G3 iBook. I think I'm following the installation instructions exactly, but everytime I go to turn the computer back on, I get nothing. When I take the card out, the computer turns on just fine.

Obviously I don't have the card installed right. I've looked all over the apple site for help, but none of the documents help. I'm beginning to think that the G3 iBook can't take an airport extreme card. The card doesn't seem to fit into the slot like it's pictured.

Can anyone give me any insight into my installation problems? Is it a "technique" problem with how I'm putting the card in, or is it simply that this is the wrong card for this computer?

DGFan
May 14, 2004, 09:22 PM
I thought the G3 iBooks could only use Airport, not Airport Extreme

dansuz1
May 14, 2004, 09:27 PM
Is there some place that I can check that will tell me what is compatible with what?

RBMaraman
May 14, 2004, 09:55 PM
Is there some place that I can check that will tell me what is compatible with what?

From Apple.com:

When sold separately, the AirPort Extreme Card requires one of these computers:

Power Mac G5
Power Mac G4 (FW 800)
PowerBook G4 (12-inch)
PowerBook G4 (12-inch DVI)
PowerBook G4 (15-inch FW800)
iMac (17-inch 1GHz)
iMac (USB 2.0)
iBook G4
eMac (ATI Graphics) (See Note)
eMac (USB 2.0)

These computers always come with the AirPort Extreme card built in:

PowerBook G4 (17-inch)
PowerBook G4 (17-inch 1.33GHz)

Note: An eMac (ATI Graphics) computer without a SuperDrive may be able to start up in Mac OS 9. If the computer is started up in Mac OS 9, you cannot use the AirPort Extreme Card. To regain use of the AirPort Extreme Card, start the computer up in Mac OS X 10.2.3 or later.

So, you need a regular Airport card, not an extreme card.

CalfCanuck
May 14, 2004, 09:59 PM
Here's a list of Airport compatible computers - the iBook G3 is NOT Airport Extreme compatible according to this page.

http://docs.info.apple.com/article.html?artnum=106777

" The AirPort Extreme Card is not compatible with the following computers. Attempting to install an AirPort Extreme Card in any of these computers may damage the computer and/or the card. For a list of computers that are compatible with the AirPort Extreme Card, see technical document 107440, "AirPort Extreme Card: Compatible Macintosh Computers". "

Macmaniac
May 15, 2004, 07:55 AM
I hope you have not bent any pins inside your computer, u need the Old Airport Card, lets hope nothing got broken when you tried to put the AE card in.