PDA

View Full Version : MessageUI framework




XcodeNewb
Jun 13, 2009, 06:52 PM
I am trying to use the new abilities to compose and send emails within an application using OS 3.0 and Xcode 3.1.3 GM seed.

I try to add the MessageUI framework to the project but it keeps adding it from the iPhoneOS2.1.sdk folder and it will not reference the one for OS 3.0.

I downloaded the sample project from apple called PostASong and it uses the new functionality and has the MessageUI framework attached and it references the one for OS 3.0. It runs fine in the simlator and works great. I cannot figure out why I cannot reference the same one.

I have the import statement of:

#import <MessageUI/MessageUI.h>

but it errors on that line saying it cannot find it.

What in the world could I be doing wrong? This seems sooo easy!!



MacDonaldsd
Jun 14, 2009, 07:25 AM
In the build settings make sure the Base SDK is 3.0.