PDA

View Full Version : Powerbook power adaptor - dead?


josepho
May 16, 2004, 03:42 PM
Hiya,

I'm having some major problems with my power adaptor for my Powerbook (only like 2 weeks old)... I came home from work today, and it was working fine, was just running it off the main's juice. I then unplugged it, used my PB around the house, and then came up to my desk. I moved the adaptor to a socket at my desk and plugged it in... no light. So, I tried it in another socket... no luck.

First of all I thought that maybe the fuse needed replaced... but then I tried it with the standalone plug that goes into the white adaptor box (as opposed to the AC power cord which I usually use... still to no avail.

That, to me, suggests that either the white adaptor box, or the cord which runs from that to the PB has just decided to die. Apart from phoning Apple tomorrow and getting them to replace it (how long will this take?), is there anything else I can do? Thankfully I'm not writing any essays or anything... I'm just studying for a Spanish Studies exam tomorrow... don't really need the computer for that :) I really really want this fixed ASAP, as I'm sure anyone else here would.

Thanks for any advice you might be able to dispense.

kaylee
May 16, 2004, 05:01 PM
not sure if you are aware of this, but if the battery charge is between 94% and 100% when you plug it in, it will not charge up - this is to protect the battery against short charges that could damage it. let the battery run down a little more, or even all the way down, and see if it will charge up - if it still doesn't then there is obviously a problem.

josepho
May 16, 2004, 05:59 PM
not sure if you are aware of this, but if the battery charge is between 94% and 100% when you plug it in, it will not charge up - this is to protect the battery against short charges that could damage it. let the battery run down a little more, or even all the way down, and see if it will charge up - if it still doesn't then there is obviously a problem.

Yeah, I am aware of that. However, my problem isn't symptomatic with this. When I plug in the charger usually the little ring would go either orange (charging) or green (charged). It is not lighting up at all, and the computer isn't acknowledging the presence of a charger, so there definitely is something wrong.

Thanks anyway.

crees!
May 16, 2004, 08:39 PM
If you're near an Apple Store you can take it in and they'll test it and replace it if needed right there for you for no charge since it's under warranty.

JordanNZ
May 16, 2004, 09:50 PM
My SECOND powerbook charger in just over a year, is on its way out now.. Sometimes it will work, sometimes it won't, the amount of time it works is getting less. My warranty has run out now, i'm kinda pissed about this. I would expect it to last more than 6 months!

A lot of my friends are having the same problems...

josepho
May 17, 2004, 03:15 AM
Unfortunately I'm in the UK, so my nearest Apple Store is like 3000 miles away... Anyways, I called Apple and they've arranged for a new one to be sent, though he said it'll take about 5 days... eek! Hopefully he was just being cautious.

I've got 45% of my battery... to last me 5 days. How will I survive?

Celeron
May 17, 2004, 07:23 AM
I suppose you could plug it into a wall and try a multimeter on it to see if any current is making it through. Other than that, I guess you're going to have to wait. Is there any place locally that sell them? I know you said an Apple store is far away, but maybe there is a local vendor who sells Apple gear? In that case, you could always go buy a new one from there and return the one Apple sends you.

Zeke
May 17, 2004, 07:24 AM
I had the same problem...unfortunately mine died the weekend before I had to give a presentation so I had to scramble and find one. These things are not cheap either. $70 is ridiculous. The lady on the phone at Apple was like, well, so this doesn't happen again you should buy a second one for backup. Inspires a lot of confidence doesn't it.

jxyama
May 17, 2004, 07:30 AM
same thing happened to mine... i didn't move my adapter or anything, but when i plugged my PB back in, it just wouldn't light. i tested various combinations of outlets, plugs/cords and concluded that something inside the white box was dead... tempted to open it up and see what happened...

this happened after a year and a few months of use...

edit: i forgot to mention that mine got a bit flaky a few months before it went completely dead... i hope this isn't symptomatic of the adapter. i have rev. A 12" PB, btw. it came with a 45 W adapter. the replacement available from apple is rated for 65 W but i don't think it makes any difference because it's described as compatible for all PowerBooks after Ti.

russed
May 17, 2004, 08:13 AM
mine stops working sometimes so all i do is pull the plug off the adaptor, put it back on again and it starts working again!

josepho
May 17, 2004, 11:42 AM
Thanks for all your replies guys... Looks like I will just have to wait... I just hope they get it to me ASAP.

I'll keep you all apprised of the situation.

Thanks! :)

josepho
May 18, 2004, 05:57 AM
Update 1: UPS delivered an adaptor this morning... the only problem: it's a 45W (correct) adaptor, but not a Powerbook one, rather one for an Apple Studio Display... doh :(

Phoned them up again and they're sending out the right one this time, hopefully. I should get it tomorrow if things go as they did today.

Ciao

Coolvirus007
May 18, 2004, 08:17 AM
Moniter power cables have adapters? I though it was just a straight cable from the outlet to the display. whatever.

TheMac19
May 28, 2004, 02:06 PM
i've noticed that occasionally the ring on my new powerpook's adaprter cord doesn't light up as well. I've traced the problem not to the AC adapter, but rather the actual plug into the powerbook. If it's plugged into the computer and the light isn't on (not getting power), a little jiggle gets it lit up and powered up. (Conversely if it is working properly and illuminated, if I press on the plug even slightly, the light goes off and it loses power. )
My powerbook is only a week old, I sure hope this isn't a sign of future problems. (the old laptop pc I'm replacing recently started having these problems, but that was after 6 years of use!)

Macmaniac
May 28, 2004, 06:40 PM
i've noticed that occasionally the ring on my new powerpook's adaprter cord doesn't light up as well. I've traced the problem not to the AC adapter, but rather the actual plug into the powerbook. If it's plugged into the computer and the light isn't on (not getting power), a little jiggle gets it lit up and powered up. (Conversely if it is working properly and illuminated, if I press on the plug even slightly, the light goes off and it loses power. )
My powerbook is only a week old, I sure hope this isn't a sign of future problems. (the old laptop pc I'm replacing recently started having these problems, but that was after 6 years of use!)
The connector on your PB sound like it is loose, take it to an Apple authorized Repair center and have them look at it, the problem will only get worse with more use, I'm not 100% sure but I think the connecter is a separate piece from the Logic board, if I'm wrong then its connected to the logic board so that would have to be replaced.

blueflame
May 28, 2004, 07:30 PM
i posted this on another thread but only got one response
The same thing is happening to me. its just being flaky. to fix the problem all i have to do is upplus it from the wall and plug it back in. but the time it works is getting shorter and shorter.
this is realy annoying especially becuase i am out of warrenty. i have a rev A, 17 pb.
This is annoying and im kinda pissed.
Ive been going crazy trying to figure out what is going on.
Andreas