PDA

View Full Version : AirPort troubles


johnnyjibbs
May 21, 2004, 07:51 PM
Ok, I just got back from America and treated myself finally to an Airport Extreme card for my 12" PowerBook (they're way cheaper in the States).

Got home, installed it, fine.

My uni has just started to set up a trial wireless b scheme. Currently wireless access is available in the main library and one of the computer rooms. They are using a D-link wireless b/g access point (set to just 802.11b at the moment). Bear in mind also that they support Windows XP and not Mac OS.

When I go to the library or said computer room, the network shows up on my Airport menu bar. They use WPA authentification which requires my IT username and password. (I have registered my computer with them). When I try to connect using the Airport menu, it says that authenitification fails. When I open up Internet Connect and put the settings in the 802.1x tab (including the WPA TTLS PAP protocol, which is what they use), I can then usually connect. However, the connection only lasts for about 7 seconds before it loses and has to reconnect, in which time there are NO bars of reception and I still cannot access the internet wirelessly. THIS IS TRUE EVEN IF I AM ONLY 2 METRES AWAY FROM THE ACCESS POINT. During this time, my network status in the network preferences for Aiport says "Airport is connected to a network and has a self-assigned IP address but may not be able to connect to the internet", while displaying an amber status icon.

I've had a lengthy discussion with the IT bloke at the university. He said that Macs weren't compatible, but then I found out that he was testing on a Jaguar system (which stupidly doesn't appear to support the industry-standard WPA security protocol) and had apparently never heard of Panther (which I'm using). Oddly, when in front of him, I managed to connect and get 2 bars of signal whilst in a different room. It worked fine. Therefore I know I have not got a faulty Airport card, etc.

Since then though, I've not had much luck. It connects for 7 seconds and then loses the signal, but no bars of signal ever show up in the menu bar and I can't use the internet in that time either. One of the Airport help topics mentions that this may be due to the Airport card not being in properly. However, I've opened up and tried many times and I'm sure the antennae is firmly fastened to the card. My nearest Apples Store and genius bar are about 3000 miles away.

Anyone know what's wrong? I thought Airport was supposed to be simple.

(There is a pub in my city that provides wireless access also, but it costs about 6 an hour ($10) so I'd rather not go and test using that.)

One day, when we get broadband at home, I'll buy a base station, but I'll need advice on the multitude of cheap PC access points. I'll leave that for another thread though....

superbovine
May 21, 2004, 09:16 PM
well, i haven't had that specific problem with WPA, but my airport extreme has been bitchy with WPA with D-Link equipment. Installing the updates for airport extreme will help, well a lot. My problem was it wouldn't even connect at all or i would have to connect twice. sorry if this doesn't help much :(

what other forums do you post on, you look familar?

cjc343
May 21, 2004, 09:52 PM
do they support manual IPs?

You might want to go System Preferences > Network > Airport > TCPIP and select to configure IPv4 Using DHCP if you have been using DHCP With Manual address.... if that doesn't work, tell us ALL of your network settings... they will probably help....


again, I don't know whether this will work, I haven't tried it all that much....

johnnyjibbs
May 23, 2004, 01:14 PM
Thanks for your help, however I still can't get it to work and it's driving me nuts. First of all, I have been using DHCP automatic as I don't know what information to put in otherwise. I have been told to use DHCP so I know that bit's correct.

As a reminder, the security system they are using is WPA Enterprise, using a D-link access point.

So after extensive trying, I can choose the network from the list in the Airport menu but it says "WPA authentification failed..". If I open up internet connect and run from the 802.1x tab, with the correct PAP protocol at TTLS, it says it connects but it only lasts for around 7 seconds. Then it automatically disconnects, retries and reconnects a couple of seconds later. Even though it says it's connected, I still can't access the internet and have no bars of signal in the airport menu. The Network Status for Airport shows an amber light and says it "may not be able to connect to the internet".

I have attached an image showing the IP settings that appear when it "connects": (networksettings.jpg) My IP address is 169.254.4.249, however many of the Apple documents say it should be 10.0.0...etc.

I have also attached an image showing the internet connect 802.1x settings where it has connected but will disconnect after a few more seconds: (internetconnect.jpg). Note that the AirPort menu item contains NO bars of signal.

In fact, if I have the AirPort Client Monitor running, the signal is very weak along the bottom: (signalmonitor.jpg). Note the green and blue lines at the bottom of each of the graphs.

One question: do you only get bars of signal show up once you've successfully connected or should it show up whenever you're in range of any wireless network?

I've tried to reseat the card and antannea many times and I'm sure it is connected up properly. I refuse to believe there's a problem with the AE card because it did work on Thursday when I was in the IT department, as I said in my earlier post. That's the only time I ever saw any bars of signal (2 of them) in the menu bar. Also, if it worked then whilst in a different room to the access point, it ought to work when right next to the damn thing.

I have the latest software (Airport 3.4.1). I've even tried holding down the ctrl key while connecting (forced 802.11b mode) but that doesn't work either.

cahillj
May 23, 2004, 04:02 PM
To check that your AE card is working OK you could download MacStumbler from VersionTracker. This WiFi sniffing program continually tells you signal strength of the transmitter without having to login.

cjc343
May 23, 2004, 04:14 PM
ok, I can't quite tell whether you tried this or not.


Click on the Airport Menu-Bar item and select "Other..."

Under Wireless Security, select "WPA Enterprise"

Enter the network name (I believe it was displayed in one of the pics).

Enter your user name and password.


Does it work?




The signal strength will only be displayed when connected.

One other possibility:

Try using someone elses computer to connect using your user name and password, if that doesn't work, the University never activated the user name.

Kevlar
May 23, 2004, 04:20 PM
Do they use a telnet client to connect to the network? Cause that is what my school does. Which you authenticate through the terminal before you will get an actual connection.

Try going into the terminal typing the ssh username@(router address)
and then it should ask for your password. After you do that you have to leave the terminal open until you are done with your connection.

johnnyjibbs
May 23, 2004, 04:43 PM
I've downloaded MacStumbler and will give that a try tomorrow. Thanks

I've tried connecting using "Other..." but I get the same "authenitification failed" error or sometimes "Your password is incorrect". It does automatically detect it as a WPA Enterprise network however.

Maybe they haven't enabled my username but then why would it have worked the other day then? Also, if I use a fake username it comes up with an error every time, whatever connection method I use, so it seems as though something is working regarding my username.

I guess the only solution will be to pester the "we don't support Macs" IT department again for help. Kevlar, as far as telnet clients go, I've got no idea but I could ask. I think I'd be better off steering clear of the terminal though as I'm a bit of a novice in that area. Thanks anyway.

Hopefully I can get things fixed and get wireless soon!

Kevlar
May 23, 2004, 06:18 PM
Well I have the same kind of problems at my university. TO access the any of the 6 wireless bases (stationed all over campus) you need a program which authenticates you and then you are good to go, but the problem is the program they provide is only a PC client. So I went to the people in charge of the networks and asked them how it connected and we determined that using the terminal we could authenticate any mac computer (OS X and above). Since this is built in this was the best (and simplest) way for any mac user to get connected.

So your best bet may be to go down to them and ask if you have to authenticate before you are able to get connected. Which may be the case becuase they like to be able to keep track of what people are doing on there network and can hold people responsible for any problems.

johnnyjibbs
May 25, 2004, 04:25 AM
Good news. This post is coming from my PowerBook over Airport in the library! I didn't have time to go check yesterday, but turned up today, turned on MacStumbler and was getting a good signal (therefore no problems with my card!) and then I connected using Internet Connect! It works today with 3 bars of signal and I'm at least 30m from the access point!

So now I'm enjoying wireless internet with bluetooth wireless mouse. No wires at all! I could get used to this!

No ideas why it just worked today. It must have been a fault of the network rather than anything to do with my computer. Maybe some kind of maintenance? It's currently a trial scheme after all. Anyway, a little scared to disconnect in case I can't get it back but all's well now! Thanks all for your help!