PDA

View Full Version : ATV streaming nightmares - please help




tdotto
Jun 20, 2009, 09:13 PM
I have tried everything I could... read up a lot here as well.

My setup is as follows.

1. Apple Extreme Base Station N - USB External HD connected to it.
2. Windows PC connected to the Apple Extreme Base Station, running iTunes, wired.
3. Behind the wall, 4 feet away - Apple TV 2.3, wireless
4. Adjacent to Apple TV is an Airport Express 'N' that is "extending" the wireless network.

My Problem:
I had my video files on External HD, added them to iTunes (item2), shared iTunes Library, accessed through ATV - had streaming/buffering problems. So I moved my video files to the internal HD of the Windows PC hoping for better stream. What I get is consistent problem streaming the files. Audio files are fine, but there are intermittent issues with them too.

Side note - I use my MBP to connect to the same iTunes shared library and almost never have issues playing files. This hints that the problem lies with the ATV accessing the streamed content?!

Any help to optimize my network will be greatly appreciated. I just don't want to be storing the Video files on ATV HD (even if I have 160 GB internal).



SurfMacJpMtb
Jun 20, 2009, 10:08 PM
I am curious what firmware level your Airport boxes are running.

I have a similar environment with a Base and Express extension to reach my TV. The reason I am asking about your firmware is I did not have any luck with the current firmware release, 7.4.1, and had to revert to 7.3.2 in both by Base and Express. My problem was video files would stutter (pause to load). Videos stream fine with the old release.

The current release has been out for months but I have not stumbled across the magic answer. When I originally trouble-shot the problem it was heavily discussed on Apple's forums and the answer was to revert to 7.3.2.