PDA

View Full Version : CD Stuck in Alum. Macbook




JefferyShin
Jun 21, 2009, 01:02 AM
Hello, I inserted a cd to burn some files on it.
While burning, I accidently closed my laptop, therefore putting the laptop to sleep. When I opened my laptop again, it said error, and ejected the disk. So I decided to try again, and inserted the disk. It did not recognize the disk. It spins, but doesn't recognize it.

So after hours of Googling, these are the methods I tried:
-Booting while holding down trackpad
-Booting while laptop disc slot faces downwards
-Using a knife to push spring down (could not find spring)
-Using credit cards to open up the exit
-Gently shaking laptop

I think the problem is that, in the slot <=========> <-pretend thats the slot, <====O====> , where O is a blockage occurs. I can't push, pull, press, or do anything to clear it.

Anyone got help?

Thanks,

Extra info:
MacBook 13.3in 2.0ghz Aluminum
CD is a Memorex CD-R 700MB



firewater
Jun 21, 2009, 01:11 AM
reboot and hold down the eject botton n see if that helps

Edensuko
Jun 21, 2009, 02:59 AM
This happened to me once. There wa a key you pressed at boot that will eject the disc after some time, then get in the actual OS.

Dont remember if it was N or I but im sure i found that tip on apple´s website.

chaosbringer
Jun 21, 2009, 05:31 AM
Found this on apple's site:
The drive doesn't eject discs or discs eject slowly

If the drive ejects discs slowly or appears to be struggling, insert and eject a single disc several times.
If the drive does not eject discs using the F12 or eject key on the keyboard try dragging the disc icon to the trash. If the disc will still not eject holding down the trackpad button during startup should also eject a disc.
Reset the Power Manager (PMU) or System Management Controller (SMC).
If the disc still does not eject, for additional troubleshooting, evaluation, or service please contact Apple, contact an Apple Authorized Service Provider, or make an appointment with an Apple Retail Store.


The following worked for me once (also from apple's site):
Ejecting a CD or DVD when all else fails

If you've tried all the usual methods of ejecting a CD or DVD from your computer's optical drive, there are some other methods you can try.

First, quit all applications that are using files on the disc. Then try one of these alternate methods:

Open Disk Utility (in the Utilities folder of your Applications folder), select the disc, and choose File > Eject.
Choose Apple menu > Restart and hold down the mouse or trackpad button until the disc ejects.
If your drive has an emergency eject hole, put the computer to sleep and insert a large, straightened paper clip in the small emergency eject hole of the drive (the location varies, depending on the drive). Push firmly until the disc ejects.
If all other methods fail, you can try to eject the disk using the firmware. (This may not work on all computers. For example, it does not work on Intel-based computers.) The steps below describe how to start up and briefly use the computer with only the firmware loaded, not the standard Mac OS X interface.
To eject a disc using firmware:
Restart the computer.
When you hear the startup sound, press and hold the Command-Option-O-F keys. (The Command key has an Apple on it.)
Release the keys when you see a white welcome screen.
At the prompt, type:
eject cd

Press Return, then wait a few seconds. The disc drive should eject the disc, and "ok" appears on the screen when the action is complete.
Type:
mac-boot

Press Return.

hope this helps :)

r34p3rex
Jun 21, 2009, 09:19 AM
Heh, I see this all the time at work. Can you hear the drive trying to eject the disc? If so, it's most likely due to the frame being slightly warped

Let's say this is a normal drive slot:

==================

What happens sometimes when people apply too much pressure on the key board or on the frame is the following:

======vv=======

The top layer of the frame drops down and blocks the disc from ejecting.

You'll want to grab a flat-head screw driver and run it along the slot. Divide up the slot into 8 sections. In each section, insert the screwdriver about a quarter to half an inch in and pry the casing up and down. Hopefully, this will bend the frame back upwards and clear the blockage ;)

Good luck!

robotica
Jun 21, 2009, 10:52 AM
try this and let me know ( its how i fixed the same problem )

get a biz card or some other piece of card...

switch off the mac

put the card in the cd slot and gently push down ( you are trying to stop the CD from spinning when you turn it back on )

turn the computer on while pushing down on the mouse pad and doing the card stop the cd spinning thing... after a few min it will pop out :)

good luck

JefferyShin
Jun 24, 2009, 02:03 AM
Thanks everyone, but this is how I fixed it. (a little barbaric...)

I stuck my Library and my Bank card into the drive, and started to just poke wildly at it.

Then, stupid as I am, my card went in completely(1 of them)
So I took a letter opener and started to stab wildly at the opening.

Then a bit of the cd/library card showed, so I shook my MB up and down and it fell out.

I tested a cd to see if my drive worked fine, and it does :D

Thanks everyone.

MedHead
Jun 24, 2009, 08:21 AM
Wow that is kinda barbaric but at least the drive is working ok! :P Is there still difficulty in ejecting disks?

JefferyShin
Jun 30, 2009, 04:09 PM
Hahaa yes it is VERY barabaric....

And no, it works flawlessly, inserting, reading, and ejecting. :D

acron1
Jun 30, 2009, 06:58 PM
Hahaa yes it is VERY barabaric....

And no, it works flawlessly, inserting, reading, and ejecting. :D

All I can say is WoW!!!

allyask
Jul 2, 2009, 08:27 AM
I used the reboot and hold down track pad and it worked like a charm.
Problem is... it happens every time... so it wasn't a one time wonder.
What is the next step to permanently fixing the problem. I use the CD/DVD drive often.

TsuaSai
Jul 2, 2009, 03:03 PM
Call apple they might replace it for you.

Stiss
Jul 3, 2009, 06:09 AM
i was going to say use Disk Utility, but i suppose bank cards are better.