PDA

View Full Version : Problem ripping the movie "Click" with handbrake?




ASFx
Jun 27, 2009, 06:06 PM
I've ripped many DVDs and this is the first DVD where i'm having problems. Handbrake scans the DVD ok, but then when it goes to rip, it only goes at about 3fps (i usually get 120fps), and i can hear the DVD constantly spinning up then slowing down again. The DVD finally finishes and is playable, but contains skips every few seconds. Is this due to some sort of copy protection? I exchanged the DVD thinking it was scratched, but the 2nd DVD i received did the same thing.



spinnerlys
Jun 27, 2009, 06:09 PM
Have you tried MacTheRipper to fully rip/copy the DVD to your HDD first and then use Handbrake?

MTR will show you, if there is any copy protection on the DVD, which it can't break. Is it from Sony?

I once had to rip Stranger than Fiction, and I couldn't do it with Mac OS X, so I used DVD Decrypter with some workaround in Windows and it worked.

ASFx
Jun 27, 2009, 06:33 PM
Good idea. I forgot about that. I don't have mactheripper but I do have RipIt. I'll try that and see what happens.

randy98mtu
Jun 27, 2009, 07:39 PM
I have the same problem with that movie. It must be some kind of protection. Any luck with MTR?

ASFx
Jun 27, 2009, 07:46 PM
I have the same problem with that movie. It must be some kind of protection. Any luck with MTR?

I don't have MTR but i'm using RipIt to get the files off the DVD, then i'll try handbrake again. I'll let you know what happens.

ASFx
Jun 27, 2009, 09:01 PM
It worked. I ripped the VIDEO_TS folder off the Click DVD with RipIt, then used handbrake to encode the m4v file from the VIDEO_TS directory using the AppleTV preset. :)

aneftp
Jun 28, 2009, 08:34 PM
Sony's always up to their new tricks in terms of preventing copy right protection.

Sony is just as bad (probably worse than Apple) in terms of protecting their intellectual property.

I'm always leery when I have problems ripping movies and they are almost always Sony related pictures. Yes, these are movies I purchased and I have every right to make a backup copy.