PDA

View Full Version : Powermac G4 not recognizing external HD




aggrolounge
Jul 2, 2009, 08:52 PM
I have two USB harddrives and neither of them are recognized by my G4. One of them consistently requires two ports for power, so I'm not surprised that one isn't working. However, my backup drive (a Verbatim) should not need that and it is supposedly compatible with USB 1.1 ports. It shows up on a Macbook. I am also quite sure that the ports themselves are working. What's going on here? Help!



aggrolounge
Jul 2, 2009, 11:21 PM
Oh, and disk utility DOES recognize it, it's just not in finder. Now what?

Porco
Jul 3, 2009, 08:26 PM
Are the drives formatted using GUID partition system (introduced for boot disks on the intel macs)? If you are running an older version of OS X in the G4 (like 10.3 or earlier) that could be one reason why.

Or, have they shown up on the G4 before and stopped doing so now? That would indicate something has gone wrong, either with the disks or the enclosures or the USB ports. If you can see the disk in disk utility you might want to try verifying the disc if you haven't already (maybe do it on the MacBook if you're having more luck there).

On a slightly related note you really might like to consider a USB 2.0 PCI card for your G4 if you're using USB hard drives regularly. You can also get combos that will add FW400 or 800 as well. It might not have any bearing on your current problem, but even if it didn't it'd be worth having if you only have USB 1.1 ports currently.

I am not sure what the cause of your problem is, but I wonder if it is power related. Have you tried removing your mouse /keyboard and any other USB devices on the G4 before attaching the hard drives? I'm guessing they are both self-powered by the sounds of it?

Don't know if any of that will help... anyone else?