PDA

View Full Version : iPod Photo skipping last 20 seconds of songs




GlynJones
Jul 6, 2009, 12:56 PM
Hello,
Started to get a problem on my 60gb iPod Photo. Been ripping a few albums lately as MP3's 192kbs as always. The problem is that 20 seconds from the end of most tracks it skips to the next track. I can watch the countdown and as soon as it hits the 20 seconds left ... skip ... next track.

I've read people are having this problem on another forum but can't find a definitive answer to the problem and more importantly how to fix it. Most people seem to associate this with custom cover art as opposed to the ones on iTunes.

Is anyone else having this problem? If so have you managed a workaround? is it specific to the older iPods? will it be okay on a newer classic?

The same songs play fine in iTunes and on my iPhone. If I have to buy a new iPod the so be it but it has to be a classic as i've nearly 40gb of music.

Thanks for any advice given.

Glyn.



Eriamjh1138@DAN
Jul 7, 2009, 09:43 PM
My iPod 3G started doing this recently, too. I blame iTunes since Apple hasn't updated my 3G firmware since 2004 or 2005.

I find that if I unclick the song in iTunes, sync, then reclick and resync, sometimes it fixes it (90%?). Try it.

If yours is doing it for every song, maybe a full restore?

GlynJones
Jul 8, 2009, 12:39 PM
Thanks, it was only on certain albums it did it on and these I'd only recently put on.

I tried the suggestion on the apple forum to highlight the affected albums and click on the "Part Of A Gapless Album" tab setting it to "No" and saving. This seemed to do the trick.