PDA

View Full Version : Apple TV not recognized over Wireless




dylanbrown
Jul 10, 2009, 09:07 AM
Hey all,

I have a 160GB Apple TV which was purchased about 2 years ago. Just recently I've been having problems getting my Apple TV to Sync with iTunes.

It's been out-of-use as my Samsung TV was away getting repaired (Took 3 months!) and I was left with a tiny 15" portable. When I hooked up my Apple TV when I got my TV back, I thought it would be best to wipe of all the content and do a fresh Sync. I did so (Did not do a factory restore - just removed my iMac from the computers menu, then added it again). The initial Sync went fine... but later on I found that my Apple TV was not connected under Devices in iTunes.

iTunes is set to look for Apple TV's and my Firewall is set to "Allow Specific services and Applications". I also have NetBarrier installed, and is set to No Restrictions.

A week later with no luck getting my Apple TV to Sync, I decided to do complete factory restore, after doing so and installing all updates.... no luck.

I directly connected an Ethernet Cable to my iMac to start transferring data and it worked, although, once the cable was unplugged it did not. My Wireless settings were all correct. I found out that connecting the Apple TV via Ethernet works - and searching around led me to thinking that the Wireless card inside the Apple TV may be faulty.

As my Apple TV is over 2 years old, and is not covered by Apple Care, I don't know what to do. A TV show called "The One Show" over here in the UK was talking about the Sale of Goods Act recently (With a letter to download - I have attached to this post) stating that "The law says I have six years from the date of purchase to claim damages for faulty goods from the seller not the manufacturer" The seller was also Apple.

I have tried a lot of things to see if I could get the Apple TV to show up in iTunes, from re-installing, to completely opening up my Firewall. I'm just not too sure what to do.

Your input is greatly appreciated.

Thanks - Dylan.



srl7741
Jul 12, 2009, 11:32 AM
I'm not so sure it's all that you listed. Since updating my iTunes to 8.2 I can't keep a wireless connection for more than 20 minutes. iTunes has always been perfect with no issues till that last update. If I am using aTV of course the wireless connection continues to work fine for hours. The minute I stop using the aTV the wireless drops off. When I hard wire it this does not happen.

I have not found out why this occurs yet. It's a pain having to open or shut down and re-open iTunes just before needing to use either one of my aTV's.

d21mike
Jul 12, 2009, 01:18 PM
Wirelessly posted (iPhone 3G: Mozilla/5.0 (iPhone; U; CPU iPhone OS 3_0 like Mac OS X; en-us) AppleWebKit/528.18 (KHTML, like Gecko) Version/4.0 Mobile/7A341 Safari/528.16)

I had probles with my atv loosing it's wifi connection. After 2.4 it has not happened. Keeping fingers crossed.

steve123
Jul 13, 2009, 11:22 AM
Same here, since the last iTunes update my ATV looses its connection in the device list. It will also occasionally loose connection with the router. Many people appear to be reporting this issue over at the Apple Discussion Forum.

dylanbrown
Jul 13, 2009, 12:40 PM
Update...

After a full two weeks Wireless not working, today - for some reason, it just worked.... amazing!

Must just have been a temporary problem. It happnes sometimes to be honest, and I just fix it by doing a restore, but I was stumped why it wasn't working after various restores....

Thanks for your help anyway....

Dylan.