PDA

View Full Version : Genius Playlist Causing AppleTV to Hang




mchalebk
Jul 15, 2009, 11:02 AM
I did a search on this and couldn't find anything, so I apologize if it's been discussed before.

We use our AppleTV quite regularly to listen to music. Most of the time, we use predefined playlists. However, once in a while I like to mix things up and use the Genius feature to create a playlist for us. While the feature seems to work fine, the AppleTV will hang once in a while for an extended period of time (a minute or two). During this time, the unit is completely non-responsive to commands. I believe it always occurs during the transition between songs, though I couldn't swear to that.

When this first occurred, I thought the unit was locked up and reset it. However, I finally figured out that if I leave it alone, it will eventually start playing again.

I am running the latest version of AppleTV software. I first noticed the problem 1-2 software versions ago, though I didn't used to use Genius that often so I couldn't say when it first started happening.

Has anyone else experienced this?



mchalebk
Jul 17, 2009, 02:27 PM
I've done some more searching (not just here, but on the internet) and haven't been able to find any references to this problem. It really doesn't seem possible that it's a hardware problem (since I'm not having any other issues, not to mention that this just seems like software).

It also isn't tied to a single AppleTV software version, since I had the problem before the latest software update. It just seems that other people should be seeing this if it's a software issue.

I wonder if there's some underlying file in my software that might have gotten corrupted that didn't get updated during the software update process? I'm thinking about doing a Factory Restore, then loading the latest software to see if that makes any difference.

So, anyone have any other ideas about this problem?

mchalebk
Aug 10, 2009, 09:56 AM
I finally did do a factory restore and resynced all my content. However, that did not fix the problem.

When I run genius playlists, I can generally count on it hanging up at least once for a minute or two. It seems to always be between songs (never in the middle) and it always recovers on its own.

mchalebk
Aug 12, 2009, 10:21 AM
Does anyone here use the Genius feature to playback music on their AppleTV? if so, does it work okay for you? Any issues?

mchalebk
Aug 12, 2009, 01:51 PM
Since I haven't been getting any responses here, I posted this topic in the Discussions on the Apple website. I did get two different guys to respond that Genius works fine for them. However, they're streaming from a computer, not playing back synced material.

It makes me wonder if the problem is only with synced media. You'd think that synced material (being resident on the internal hard drive) would be less likely to have problems, but who knows?

OldGuyDave
Aug 19, 2009, 03:39 AM
Since I haven't been getting any responses here, I posted this topic in the Discussions on the Apple website. I did get two different guys to respond that Genius works fine for them. However, they're streaming from a computer, not playing back synced material.

It makes me wonder if the problem is only with synced media. You'd think that synced material (being resident on the internal hard drive) would be less likely to have problems, but who knows?

I had this problem with my iTunes on my Mac and then on my ATV. It was realy bugging me. What I last did seems to have made the problem go away. (I don't know if it may come back it's working ok for a week now.)
I turned genius off in iTunes and then closed iTunes, went to the music folder and renamed the itunes folder from "iTunes Music" to "Music", (so iTunes wont find it when opening) deleted all the genius files inside the iTunes folder. (Sorry I'm not at my Mac now but there was a file, with an ending like .tdb and Genius in the name) then I started iTunes and redirected it to the new "Music" folder, let it start and then I started my atv as well. Went into settings and turned the genius back on, did a sync with my atv and now no problem. Hope this helps.
P.S. In my case genius was making my iTunes on the Mac hang as well as the atv to hang.
Cheers

mchalebk
Aug 19, 2009, 08:44 AM
Thanks for the input. I haven't used Genius playback on my computer, so I don't know if I have the problem there. I'll give this a try to see if it fixes it.

mchalebk
Aug 24, 2009, 09:45 AM
I tried OldGuyDave's suggestion. However, I could never get it so iTunes couldn't find my library (I tried multiple renamings, but it always located it). However, it occurred to me that deleting the genius database file might be the answer anyway, so I proceeded with it.

It does seem to be working better, but the problem has not gone away completely. It seems like the problem only occurs maybe once every other genius playlist, instead of 1-2 times (or more) per playlist.

So, maybe there were some issues with the genius database file, and the new one has less issues? I suppose it might be worth deleting it again and seeing if it clears things up. Right now, it's only moderately annoying, so I might just leave it alone unless it gets worse.

OldGuyDave
Aug 26, 2009, 02:08 AM
I tried OldGuyDave's suggestion. However, I could never get it so iTunes couldn't find my library (I tried multiple renamings, but it always located it). However, it occurred to me that deleting the genius database file might be the answer anyway, so I proceeded with it.

It does seem to be working better, but the problem has not gone away completely. It seems like the problem only occurs maybe once every other genius playlist, instead of 1-2 times (or more) per playlist.

So, maybe there were some issues with the genius database file, and the new one has less issues? I suppose it might be worth deleting it again and seeing if it clears things up. Right now, it's only moderately annoying, so I might just leave it alone unless it gets worse.

I really don't have a clue as to what ther problem might have been, it seems that when the genius feature reads my music library at some point it has a problem, (no idea why) so that's why I wanted to force it to re-read my library, it might help when you re-read your library as well. There's a menu item somewhere, I think under "File" that lets you do that. (Sorry not at my Mac now) That's all i really did, Turn genius off, delete the genius database, re-read the library, start genius again, then re-sync with the aTV. The problem hasn't come back since I did that. (knock on wood) :D