PDA

View Full Version : Has VLC killed my MacBook?




RedTomato
Jul 25, 2009, 10:22 AM
Wirelessly posted (Kaiser phone: Mozilla/5.0 (iPhone; U; CPU iPhone OS 3_0 like Mac OS X; en-us) AppleWebKit/528.18 (KHTML, like Gecko) Version/4.0 Mobile/7A341 Safari/528.16)

My macbook just died.

I was watching an old 1950s movie on VLC, with subtitles. The subtitles were a bit large so I stopped the movie and reloaded it, setting VLC to use a smaller subtitle font.

Suddenly everything slowed down, Finder became like molasses, taking 30 seconds to respond. I force quit VLC, which took a long time to happen, and restarted Finder. It took ages to come back up, and got slower and slower, even after another forced quit. Eventually I force-rebooted my MacBook by holding down the power button.

On restarting, it refuses to boot, staying at the grey screen with grey apple and spinning circle for over half an hour. Eek!

Has VLC killed it?

More info: White MacBook 2.2ghz, 4gb ram, 300gb hard drive, fully updated 10.5.7. No new hardware for the last 6 months, used daily for work, few apps added, no haxies, very reliable. Can't remember the last crash or freeze I had on it.

Any ideas? I've reset the PRAM but that hasn't helped :(



OrangeSVTguy
Jul 25, 2009, 10:32 AM
Try to boot off your restore CD, run disc utility and try to "repair" your hard drive.

RedTomato
Jul 25, 2009, 10:51 AM
Wirelessly posted (Kaiser phone: Mozilla/5.0 (iPhone; U; CPU iPhone OS 3_0 like Mac OS X; en-us) AppleWebKit/528.18 (KHTML, like Gecko) Version/4.0 Mobile/7A341 Safari/528.16)

Forgot to add: it boots into Windows XP perfectly fine in Boot Camp.

Ok, I've just done an SMC reset as well. No joy.

Dug out my old OS X Leopard DVDs and booted via the DVD into OSX installer. Strangly the screen backlight went off. I had to squint at the dark screen to see anything but nevermind. Went to disk utility, ran repair disk, all fine. Ran repair permissions, lots of errors, but in stuff like iChat, iTunes, nothing showstopping. Finished successfully.

Restarted, screen backlight came back on (phew) but MacBook still stuck for last 15mins on grey startup screen with spinning circle of doom and grey apple logo. :(

Kat King123
Jul 25, 2009, 12:40 PM
Press the Power button, and immediately press and hold down the Command key and the S key as the machine starts up. This boots you into Single-user mode and you should see white text appear on the screen.
When you see the # command prompt, type /sbin/fsck –fy (“fsck” is a file system consistency check utility) and hit Return. Now sit back and let your MacBook attempt to find and fix whatever problem is plaguing it. This could take 15 minutes or so—or even longer if things are really messed up—so 
be patient.
If and when you see the message “File System was modified,” repeat the step above again, and again, until 
you finally, hopefully, see a message saying, “no problems were found.” When that happens type reboot and hit 
Return again....

RedTomato
Jul 25, 2009, 03:13 PM
Kat King Thanks for the single user tip. I tried that and it restarted into single-user mode. At least I have command-line access into my laptop.

Ran fsck several times. First time it said 'File system modifed' but not on the second or third times. Just to make sure, I rebooted again into single-user mode, and fsck came up clean.

Rebooted into full mode, and got the same perpetually spinning wheel and grey apple. After leaving it for 30 mins, rebooted again into single user and ran fsck again, which left a warning 'File system has been modified'. Ran fsck again and rebooted but same results as before.

I tried to reboot into safe mode, but it still stuck at the spinning wheel. Didn't get the the words 'safe mode'. Maybe I'm pressing shift at the wrong time.

Now what?

iLog.Genius
Jul 25, 2009, 03:35 PM
Press and hold SHIFT before the chime. You can hold it until you get to the login screen. It is normal for Safe Boot to take a while. How long did you wait?

(as to the original assumption, VLC didn't do anything. There is something wrong with the HDD and/or files.)

RedTomato
Jul 25, 2009, 04:15 PM
I found a useful Apple page:

"Mac OS X 10.4, 10.5: Gray screen appears during startup"
http://support.apple.com/kb/TS2570

Pretty much everything you've been saying. Useful tip from there:

If you want to see the status of a Safe Boot as it progresses, you can hold Shift-Command-V during start up (instead of just Shift).

Just tried that. Wow, much more useful info. A summary:

Mach kernel loaded
drivers loaded
BSD notice shown (c) Regents of University of Calfornia
ACPI loaded
Little Snitch started
BT loaded (I think) or detected / identified
Firewire detected / identified
BSD root identified as disk0s2
Journal replay done

Then the last few lines are:

AppleYukon2 : bla bla bla (gigabit ethernet adaptor)
Bluetooth: CSRHIDTransistion transistion complete.
[HCIController][configurePM] power parent ready after 1 tries
Jettisoning kernel linker.
disk0s2: I/O error
disk0s2: I/O error
disk0s2: I/O error
disk0s2: I/O error
[repeats slowly]

At this point, I'd write it off as a bad HD, but BootCamp loads, and fsck passes it (on the second try. )

:confused:

RedTomato
Jul 25, 2009, 04:27 PM
Just tried it again, and got different results:

AppleYukon2: Marvell Gigabit adaptor detection bla same as before
AppleYukon2: RxRingsize bla same as before
Jettisoning kernel linker

disk0s2: I/O error

0 [firstlevel3] [readUID 0] [Facility com.apple.system.fs] [ErrType IO] [ErrNo 5] [IO Type Read] [PBlknum 250198248] [LblkNum 0][FSlog msid xxxxxxx something]

0 [firstlevel3] [readUID 0] [Facility com.apple.system.fs] [DevNode devfs] [MountPt /dev] [Path /dev/disk0s2] [xxx something]

(sorry didn't have time to type up these lines fully before they scrolled off screen)

then a while later:

localhost fseventsd[29] event logs in /.fsevents out of sync with volume. destroying old logs.

Kat King123
Jul 25, 2009, 05:38 PM
alright, try single-user mode once again but try typing exit this time instead of reboot

RedTomato
Jul 25, 2009, 07:04 PM
OK, I grabbed a copy of Alsoft DiskWarrior (4.1.1.) and rebuilt the directory of the OSX partition. First run found a few errors, nothing major. Second run found nothing.

Rebooted in single user mode, ran fsck twice (only the first run gave 'filesystem modified') and typed exit. Got:

:/root: exit
logout
Jettisoning kernel linker
disk0s2: I/O error
disk0s2: I/O error
disk0s2: I/O error
disk0s2: I/O error
disk0s2: I/O error
...

I'm on the point of wiping the HD and reinstalling from Time Machine. Watching a 1950s film in VLC shouldn't cause me to loose my entire OS.

RedTomato
Jul 25, 2009, 07:34 PM
This is pretty much exactly what happened to me. Total system failure in the middle of a routine operation:

http://discussions.apple.com/thread.jspa?messageID=8143137

Solved by doing an archive and install. Guess that's what I'm gonna have to do too. Or a restore from TM.

Kat King123
Jul 26, 2009, 12:17 AM
time machine might be a better option because of having a lot of previous system folders laying around if u do an archive and install plus time machine is faster i restore from backup every 6 months just to keep things clean usally takes about an hour from a usb drive:) good luck

RedTomato
Jul 26, 2009, 04:09 AM
I ran an overnight full surface scan with Drive Genius, and in the morning it was still stuck on 93% scanned, with 95 bad sectors found.

Not sure how many bad sectors is normal, but it seems that's where the problem lies. I have an up to date TM backup, but I've never done a full restore from TM, and I don't fully trust it. I'm gonna try to use Target Disk mode to copy just my important files over to another drive, then do a restore from TM. If that screws up then at least I still have my important files on a third drive.

I'm probably going to have to buy a new drive in the near future. I was just hoping my drive would hand on another year, then I could buy a SSD. $250 / £200 for 128 GB isn't enough space for me at the moment (I have a mostly full 300GB internal). Next year, $250 for 258GB would be perfect. :mad:

Kat King123
Jul 26, 2009, 10:50 AM
why dont u trust time machine its exactly like cloning your drive except that you need to put in your install dvd for it to work. ive used it countless of times never had an issue. its probably not your hard drive thats the problem its probably you, you may have installed alot of programs, partitioned your drive to many times,etc. but that should be fixed by restoring from backup. so please for the love of god just use what apple intended for you to use:rolleyes:

heatmiser
Jul 26, 2009, 11:27 AM
Time Machine is unnecessary. Go with Superduper or CCC; either allows you to store a fully bootable backup on an external hard drive, and boot from that.

iLog.Genius
Jul 26, 2009, 07:00 PM
Time Machine is unnecessary. Go with Superduper or CCC; either allows you to store a fully bootable backup on an external hard drive, and boot from that.

But if he already has a Time Machine backup that's already up to date, why would he waste time creating an image using another application. He can restore using his TM image during the reinstall of OS X.

RedTomato
Jul 27, 2009, 06:31 PM
Wirelessly posted (Kaiser phone: Mozilla/5.0 (iPhone; U; CPU iPhone OS 3_0 like Mac OS X; en-us) AppleWebKit/528.18 (KHTML, like Gecko) Version/4.0 Mobile/7A341 Safari/528.16)

Guys please don't argue. My personal files are valuable. I have email going back to 1993 on my MacBook (in a text file not in Mail.app, which itself has mail going back to about 1999.). I have two Time capsule backups, one at work and one at home, but it's been 2 years since I last burned a backup DVD and I never got round to properly and fully testing the TM backups. A backup that hasn't been tested is almost as bad as having no backup at all.

So I copied 170gb of my most valuable files over to a spare external last night. Fortunately my MacBook still worked in FireWire targe mode and I was able to use my old PowerBook to copy them overnight. It should have taken about 2 hours, but took over 10 hours to do.

I then erased my MacBook drive and used disk utility to write zeros to every sector so that bad sectors would be remapped. It should have taken about an hour but was stuck at about 90% for over 2 hours. I aborted it then checked my drive SMART status. Failing. Huh, it didn't say that yesterday when I last checked it.

So, it's official, I have a dead drive. Will order a new one in the morning.

Two things misled me. One was that drive didn't fail abruptly, osx just sort of became sticky over the course of about 10 minutes while I was doing something as harmless as watching a video file. I've dealt with about 5 or 6 drive failures from friends and coworkers but never one like this.

The second thing is I hadn't realised how cheap drives are now. I knew about ssd drives but I had no idea a decent 500gb laptop drive is only about 60 quid. Bugger that overpriced SSD rubbish, I wish I'd just ordered a new drive instead of wasting my weekend trying to fix my drive. I paid about £150 for my 5400rpm 320gb and now it's only £40 for the same model, new.

Oh well, thanks for all your help, people of this thread.

RedTomato

EDIT: see http://forums.macrumors.com/showthread.php?t=753380 for someone who lost many files after relying on a TM backup.