PDA

View Full Version : TV Shows just won't sort correctly - what am I missing?




ss957916
Aug 3, 2009, 06:38 AM
I have Black Adder Series 2,3 & 4. In list or cover flow view, iTunes sorts them correctly, but in the DVD cover view it sorts them 3, 4 and then 2. All the Sorting criteria is correct. What am I doing wrong??

And Extras is doing the same - series 2 first.



ss957916
Aug 3, 2009, 07:10 AM
In fact a lot of them are doing it - The Office and The IT Crowd too.

NightStorm
Aug 3, 2009, 07:41 AM
I have the exact same problem with Battlestar Galactica... when in grid mode they are ordered season 2,1,3,4. In list or coverflow mode they are 1,2,3,4. I've tried everything I can think of (i.e. all tagging is correct) but nothing seems to work.

RumMunkey
Aug 3, 2009, 03:38 PM
Wirelessly posted (Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10_5_7; en-us) AppleWebKit/530.19.2 (KHTML, like Gecko) Version/4.0.2 Safari/530.19)

Two things to check to get grid mode working right:



First, iTunes wants to sort by "Title" first, then by "Artist", so make sure those field are filled in. For TV Shows, under artist you can just do "Battlestar Galactica", but make sure EVERY EPISODE has this filled in. Even 1 ep missing this tag can blow grid view.



Third, is the YEAR field. Make sure there are ALL filled out for EVERY episode. I use the year a given show aired (say "1997", "1998" and so on), but in a pinch you could just use "1" for season 1, "2" for season 2 and so on.



That should fix your grid view assuming you haven't messed with iTunes default "View -> Sort TV Shows" setting and your "Sort" tags.



Trust me, I spent about 3 months (on and off) trying to figure this out but I finally got it.

DavidClassic
Aug 4, 2009, 08:10 AM
Try checking this thread. Link (http://forums.macrumors.com/showthread.php?t=559945) Try changing the 'sort show' tag on the seasons e.g. Battlestar Galactica season one would be

Battlestar Galactica 1

This is what I did for my out of order shows and it worked.