PDA

View Full Version : iweb ftp help please




haverawcake
Aug 6, 2009, 08:44 AM
I have been experimenting with Rage SEO which seems great in theory, but I can't seem to get it to work in practice.
I have put title, meta and alt image tags into pages using the SEO tool
It does not seem to work publishing the whole website using the built in ftp but I can understand that - iweb cannot seem to manage to publish my whole site that way either - it seems to need it published in bits. However, it will happily publish changes.
I thought the answer might be to try an external ftp like cyberduck/fetch to publish those optimised pages.
I have used cyberduck to publish individual pages like a verification file to goolgle and a sitemap and that all seems to work.
However, when I try to publish the optimised page via cyberduck or fetch the title tags and alt image tags do no show up on the home or cake/sweet making page. They do show up on the index page.
I have even deleted that page from the server using the ftp and then uploaded the new one and it still does not show up. However, when I open that same page from my saved folder I see the optimised title tag I added using the SEO tool.
I am sure I am missing something here and maybe someone can explain. This is my first iweb website and a new venture so I do not know a huge amount about html and seo, but am learning as I am going and am doing it all myself.
Thanks, Annette

Just wanted to add.
I tried altering a page with iweb and saving to a folder. Then I and uploaded just that page with cyberduck and found that the alterations did not work either, so I get the feeling it is nothing to do with the adding of the tags and something to do with how I am uploading.
Is it something to do with the way that cyberduck and iweb upload that they are not linking to each other? Or is there another file I need to upload as well?
It would be a pain to have to upload the whole website again as it takes ages and I have to do it in parts as it is too big to do together.
Annette



Cerebrus' Maw
Aug 6, 2009, 07:10 PM
I agree that that the problem probably is not with the SEO tool, but rather how you are uploading to your Host.

I find the most common mistake people make with FTP's, is that they forget about page structure. Your new uploaded pages must go where the link specifies.

EG. www.yourwebsite.com.au/recipes/easy/cupcake.html

The cupcake.html file should be uploaded to a folder on your server via cyberduck to:

/recipes/easy/

Many people just dump files onto root ( / ) and expect the files to be found "auto-magically". :P

Finally, a lot of time, html files can be cached by your browser to save on download time. Click on Safari in your menu bar and go Empty Cache. This will make Safari get a fresh copy of your file, and should reflect any changes you've made.

If this still doesnt work, on your FTP, navigate to a page you know works (/recipes/cupcake.html for example) and delete it. Empty your cache and try going to that page via Safari. If you get (Error 404: File not Found) then at least you know that your FTP is working, and pointing to the right server. If not, then your cyberduck really is not working, and more then likely is pointing to the wrong domain. (Do you host more then one site?)

Disclaimer: When I say delete the file above, I'd advise keeping a back on your own mac :D )

haverawcake
Aug 7, 2009, 04:49 AM
Thanks very much. All sorted out now. I've backed up too!