PDA

View Full Version : Photoshop CS compatibility with Leopard OS X




BobVP
Aug 6, 2009, 02:01 PM
Question: I am on the verge of installing Leopard on my MacBook and only have an old Photoshop (7.0) which I know is not compatible. I don't want to lay out the cash for a new CS4, so here's my question:

If I buy a much cheaper used CS (not CS2, CS3 or CS4), what are the issues (if any) with Leopard?

Thanks for any guidance.



FF_productions
Aug 6, 2009, 02:10 PM
Photoshop 7/CS/CS2 will work on your MacBook, albeit slow because it is running under "Rosetta", converting PPC code->intel.

SwiftLives
Aug 6, 2009, 02:36 PM
Your best bet is to grab a copy of CS3, as that is the first Intel-native release for the Mac.

Running under Rosetta has...issues.

Alternatively, if you are a student (or know any students, teachers, or educational employees), hop on the educational discount to purchase Adobe products.

opeter
Aug 7, 2009, 04:31 AM
Another vote for the CS3 version. It works great and is also very stable on Intel Macs.