PDA

View Full Version : WiFi Disconnection Problems




Spyderturbo007
Aug 7, 2009, 07:50 AM
After searching the internet last night for about 4 hours and trying every possible solution I can find, I'm still having the same problem. I thought posting my specific details might help.

Every 5 to 10 minutes, my MBA "seems" to disconnect from the internet, although according to my Mac, it's still connected and shows my current IP address. I know it's not my router (Dlink DIR-624) because everything else stays connected. I don't have a problem with my Dell laptop, AirPort Express (used only to stream iTunes to my home theater), iPod Touch or either of my iPhones. The problem only occurs with the MBA.

Renewing my DHCP Lease fixes the problem for a couple minutes, but then I lose connection again.

Here is what I've tried so far:

-Installed all updates
-Repaired disk permissions
-Updated router firmware
-Turned off IPV6
-Assigned static IP address to MBA
-Moved from WEP to WPA and then to WPA2 encryption
-Changed router channels multiple times, from 6 to 9 and then 11
-Deleted and recreated all keychain entries related to my wireless network
-Changed keychain entries to "Allow all applications to access this item"
-Removed all saved networks, except for my home network.

I've read that you need to remove RealPlayer Updater from the list of Login items, but I don't seem to have that installed. At least not that I could find.

This is driving my crazy and any help would be appreciated. Thanks!



wrg
Aug 9, 2009, 12:00 PM
I think I have a similar problem. The problem started after I upgraded to 10.5.8. WiFi is not just disconnecting, though; it is completely shutting off. I have yet to find any way to turn it back on except to restart. After restarting, it is automatically back on, but then it appears to randomly turn off again within 5-20 minutes . . . until the next restart. Ugh.

stoconnell
Aug 9, 2009, 01:45 PM
I think I have a similar problem. The problem started after I upgraded to 10.5.8. WiFi is not just disconnecting, though; it is completely shutting off. I have yet to find any way to turn it back on except to restart. After restarting, it is automatically back on, but then it appears to randomly turn off again within 5-20 minutes . . . until the next restart. Ugh.

Do you see any entries in /var/log/system.log related to wifi when the drop outs occur? Have you reset your PRAM, repaired permissions, etc? It could be a hardware issue, too. Which model MBA do you have?

ml02kr
Aug 13, 2009, 01:57 PM
my airport seems to disconnect only for a matter of seconds, it happens sometimes every 10 minutes, every 30 minutes, or even a few hours when i am lucky, and i cannot seem to find out what the source is, everything is all up to date, so I was wondering if anybody else experienced this?:eek:


PS 2 other computers wireless in my house no problems, iBook and Powerbook

Spyderturbo007
Aug 17, 2009, 09:36 PM
I ended up getting my problem fixed.

I read on another forum that the Airport express "has problems" with older routers. I'm guessing that conflict was causing the rest of the network to become unstable.

So, I purchased a DLink DIR-625 from Amazon for $54.99 and that solved the problem. Everything has been completely stable for the last two hours. I have the MBA, two iPhones, one PC, an Xbox 360, Airport express streaming iTunes and my ReplayTV all running at the same time with no problems.