PDA

View Full Version : iMac G5; Forum where they discuss technical problems?




Waterfiends
Aug 20, 2009, 01:16 PM
Hi there,

Recently i bought a iMac G5, with iSight. The screen had a horizantal line in it. I replaced it but i dont see any "image". The backlight is working perfectly as i see it glow. But i dont see any image appearing, no grey, no apple logo, just the backlight glowing.

I think there is a cable loose, is this possible? I've check everything twice, but havnt found anything.

If nobody here knows the answer. Are there forums for more technical discussion?

Thankyou!



MTI
Aug 20, 2009, 03:44 PM
I take it that you can hear the system start up normally, just no video display.

It's possible that there's a fault with the video data cable; either broken or disconnected.

If you have an external monitor and the video adapter cable, you may be able to check if the video card is sending a correct video signal to the external video port, which would rule out an issue with the graphics processing unit (GPU) and the rest of the video circuits and logic board.

rtrt
Aug 20, 2009, 03:47 PM
don't have a particularly technical view but if it were me and i was sure i'd done all the cables back up correctly then i'd suspect the new screen might have a problem or maybe the imac has developed a new fault :(

if you put back the old screen and it works apart from the line, then the imac doesn't have a new fault and assuming you put the old one back exactly as you'd installed the new one, then you most likely have a faulty new screen.

when you remove the new and put back the old, you might discover something you missed when you installed the new. you can remedy that and all might be ok :)