PDA

View Full Version : iMac G5 hangs on startup




rocs(h&rpf
Aug 22, 2009, 03:46 PM
I've got a 1st generation iMac G5 (I think, from 2004) running 10.4.x that has become 'the family' computer since I upgraded this past winter. I haven't been keeping up with updates and decided about 3 weeks ago to finally go through and update everything; had been at least 4 mo.s since the last update and udates included Java Script, iTunes and a Security Update.

I started downloading the updates then quit Safari (which had previously been running) walked away to do other things around the house (since it would take a while) and when I came back I had an error message that the logout (to restart - which was required for the Security Update) had timed out because Safari would/could not quit. I clicked OK, force quit Safari and shut down the computer (since no one was going to be using it for the rest of the day and a restart was required anyway).

Came back the next day to startup the computer and it just hung at the blue screen with the mouse arrow. Assuming there was something wrong with the update that was just installed OR the startup disk I reset the PRAM/NVRAM: no change. Tried starting in safe mode: wouldn't (and still won't) move past the blue screen with spinning gear. Tried to boot from install disc to repair the HDD with Disk Utility: Couldn't repair the disk volume (Invalid leaf record count: should be 13 was 1203). Tried single user fsck: scanned twice and reported volume repaired, went to restart - still hangs, tried to boot in safe mode again - still hangs at blue screen with spinning gear. And that's where I'm at now.

Anyone got any good other ideas out there? I've searched a lot and haven't found anything I haven't tried. I'm guessing the installed update(s) never completely installed and screwed something up on the startup disk. But I can't access ANYTHING to figure out if that was the problem.
I would really like to keep this computer for the kids but don't want to spend any money on it if I can avoid it.

Thanks, in advance, for the help!

:apple::confused:



Hellhammer
Aug 22, 2009, 04:06 PM
Try reinstalling OS X. HD may be broken so if you can't reinstall, you have to buy new HD. Don't worry, HDs are cheap, you can get one for less than 50$