PDA

View Full Version : Apple Tv keeps dropping out of iTunes




CultHero
Aug 23, 2009, 07:47 PM
despite showing up in the preferences as "syncing" it fails to show up in iTunes and I can't access any movies (which I have to stream to it). I have tried rebooting both my iMac and the Apple TV and still it won't connect. The Apple Tv is really really full, but at this point I can't even open it up to manage it.

What gives? Any work arounds to this?



rogervzv
Aug 24, 2009, 09:27 AM
This could be caused by your Wi Fi network having insufficient signal strength. I have two Apple TVs and had problems with one of them similar to what you describe. The solution was to relocate the Apple TV to where it got better signal strength from the Wi Fi network.

Do you have dual channel Wi Fi with one band dedicated to the Apple TV? If not, and instead the Apple TV and your internet access are sharing the same channel you can have bandwidth issues that will cause problems similar to what you describe.

CultHero
Aug 24, 2009, 11:25 AM
never been an issue before and it says it has full signal.

xraydoc
Aug 24, 2009, 08:41 PM
Your problem is a common one, and there is no one solution that seems to work for everyone.

Try rebooting your wireless router. If its an Apple unit, make sure you've got the latest firmware. If you can, run 802.11n at 5MHz for the least possible interference.

If the problems have started recently, it's possible one of your neighbors has equipment that is interfering.

If you can, connect the Apple TV via ethernet. I have far few issues with my ethernet connected Apple TVs than with my wireless one.

jataga
Oct 16, 2009, 09:47 PM
All, I'm a PC user and over the past few days, my AppleTV has been dropping out of itunes for no what seemed to be no apparent reason. I loaded iTunes on different PCs, entered the access code in iTunes and every time, the AppleTV would drop out after about 5 minutes.

I was reading a little about WEP and other security settings and I remember that before i upgraded to a different access point, i was only using MAC address filtering and nothing else. When i installed the new access point, I didn't use MAC filtering and only WEP.

SOLUTION:
Something with the encryption i was using because i turned the encryption off and turned on MAC filtering. I need some type of security even though MAC filtering isn't that great. Anyway, it works like a charm. Apparently WEP or WPA doesn't work well with the latest versions of appleTV and/or iTunes.

I hope this helps.