PDA

View Full Version : Maxtor Hard Drive Problem... help!


cwright
Jul 2, 2004, 06:53 PM
I have an old Firewire Maxtor drive that refuses to mount in OSX (panther).
There is some important data on it... but I have run out of options, so hopefully someone will have some better ideas.

When I plug it in, System Profiler recognizes a device on the firewire bus, but the drive won't show up in the finder, disk utility, disk warrior, anything.

Can someone please let me know how to force a drive like this one to mount?

Thanks!

(edit...accidently published the thread before it was finished... :rolleyes: )

jsw
Jul 2, 2004, 07:08 PM
Just out of curiosity, do you have dual-boot capability (i.e., can you boot into OS 9)? If so, that might be a quick thing to try before doing anything more drastic. Would only take a minute to find out, and then you could copy the stuff over and reboot into OS X.

mr_mac
Jul 2, 2004, 07:11 PM
Disk warrior is the best data recovery tool.

If it does not work, you'll have to go with a Data extraction company that are going to charge big bucks to get your data back.

Hope this helps,

Mrmac

cwright
Jul 2, 2004, 07:11 PM
No, I haven't used OS9 in almost 2 years now...

In case it helps, I have 2 other internal hard drives that have been working fine. I have also tried plugging in this drive into my brother's iMac and the same thing happens, so this is a problem with the drive, not the computer

cwright
Jul 2, 2004, 07:14 PM
mr mac... how is DiskWarrior a data recovery app? I thought it only defragmented hard drives. I know this helps speed up the drive, but how does it recover lost data?

I know that there are plenty of key combinations that do different things if you hold them down on startup... is there any key combination that will mount drives that are being stubborn?