PDA

View Full Version : New Battery in Pismo bizzare problem


Moo-Boo
Jul 8, 2004, 08:40 PM
Greetings my Macintosh faithful,

Good to be with you once again. I have a PowerBook G3 500 Pismo, which is working magnificently, but the new battery I bought for it seems to be, um, well, almost possessed! I had it for two weeks, it was behaving satisfactorily, but then I noticed that it began to discharge awfully quickly. This went on for a week, then, next thing I know, it refuses to recharge in the PowerBook, even when the machine is asleep! Swapping it to the DVD-ROM slot didn't produce anything positive, either. This battery has a 12 month warranty. I spoke to the reseller and he is baffled too. He has sent my inquiry off to the manufacturer, and I am awaiting what will be an enlightened answer. Nothing so far.

So, I brought this problem to you, as you are most enlightened and wise.

What do all of you think? I'd be tempted to take this mystery to Scooby-Doo and Daphne, but, unfortunately, they're fictional characters.

Thank you once again for indulging me,

Matt

Mord
Jul 14, 2004, 05:22 AM
what type of battery did you get an apple one or a 3rd party one

Phobophobia
Jul 14, 2004, 06:56 AM
I'd be tempted to take this mystery to Scooby-Doo and Daphne, but, unfortunately, they're fictional characters.


That's just what the government wants you to think. Meet me under the West Street Bridge, TELL NO ONE.

Dave00
Jul 14, 2004, 06:59 AM
Sounds like you got a bad battery. When I was getting a new battery for my own Pismo, I found out that a lot of the batteries out there for the Pismo are actually refurbrished, especially the ones with too-good-to-be-true prices. This is not often readily advertised by the merchant. Your battery's behavior sounds exactly like my old battery when it reached the end of its life. Get a new one.

Dave