PDA

View Full Version : Ipod click wheel responsiveness




Grolubao
Sep 20, 2009, 01:19 PM
Hi to all,
I'm a proud owner of a Ipod 40gb 3g and it has worked flawlessly for all these years. Now I bought a 160gb Ipod classic because my previous one has reached it's capacity.

After I tried I was really disappointed with the click wheel's responsiveness. It's laggy and I have to use my thumb, otherwise it simply doesn't react.

I guess I'll return it and buy an used 5.5g 80gb because I've heard those are ok.

Any of you also have this problem?



creon
Sep 20, 2009, 01:50 PM
Sounds like a defect.

Click wheels usually have Zero lag and if they do it is a part/software problem.

Grolubao
Sep 20, 2009, 04:31 PM
Yes, but for example, my Third generation 40gb Ipod I can use the tip of my index finger to rotate the wheel but here I have to press the whole finger so I can do it, so in the end with the thumb is better.

Companies cut on the costs and now it's this, a bunch of disappointments..

surgedc5
Sep 21, 2009, 03:14 AM
my 80gb classic haves this problem, i believe all classics are like this due to big capacity hdd in 1.8" form and os making it spin too much

my old 30gb video didnt have this problem, click wheel was very responsive

Grolubao
Sep 21, 2009, 05:41 AM
my 80gb classic haves this problem, i believe all classics are like this due to big capacity hdd in 1.8" form and os making it spin too much

my old 30gb video didnt have this problem, click wheel was very responsive

Yep, that's what I've read. I'll just buy an used 80gb video ipod.

Thanks!

iEvolution
Sep 21, 2009, 08:39 PM
There had to be a manufacturer switch when they introduced the classic, I have a very hard time believing the lag is caused by the hard drive.

Since the device never ever revs up the hard drive when I quick scroll through menus its very hard to believe.

I think its simply a poorer quality click wheel being used since the 5th gen videos.

surgedc5
Sep 23, 2009, 04:44 AM
There had to be a manufacturer switch when they introduced the classic, I have a very hard time believing the lag is caused by the hard drive.

Since the device never ever revs up the hard drive when I quick scroll through menus its very hard to believe.

I think its simply a poorer quality click wheel being used since the 5th gen videos.

when the click wheel doesnt respond, you can feel the hdd spinning, and album art takes forever to load when browsing in coverflow