PDA

View Full Version : Noise and pops using iMac for audio playback




elvis.anonymous
Sep 24, 2009, 10:44 AM
I am using my machine to to play CD's and digital files through the headphone output of my iMac to an audio power amplifier, and am getting many incidents of hum and loud pops when the player is not active, and the volume control is all the way down. I have checked and rerouted the cable away from any power source, connected a different amplifier, moved the computer and nothing seems to have a lasting effect.

I have noted that the noise often occurs when I open a browser and navigate to a site that may have audio associated with it, or when I open a folder with media files, (not iTunes so far), but it is not limited to those occasions. The noise lasts long after I close the window or folder, and usually quits abruptly, not a slow fade.

Has anyone else had a similar problem?



ChrisA
Sep 24, 2009, 12:01 PM
Sounds like if the audio output device is switched on by software and then no signal is sent to it then it is noisy. Looks like you have discovered the limitations of the built-in audio. Most people use lower end audio gear and don't notice.

I think the only option is to buy a better quality audio interface, one that connects via USB or Firewire. There is no shortage of professional quality, studio grade audio interfaces. So many that it will take a while to figure out which is best. (Specs and user manuals are all on-line, read up.) For your needs prices are on either side of $100 but could go much higher of you get into audiophile grade standalone DACs, optical cables and so on.

I'd look at something like one of these:
http://www.sweetwater.com/store/detail/Alpha
http://www.sweetwater.com/store/detail/FastTrackUSB/

One other thing: If you amp has SPDIF input use that. I think all iMacs have a combo line-out/spdif jack.