PDA

View Full Version : Help! Mac Pro keeps crashing, not sure why




Ollie Cromwell
Sep 26, 2009, 07:19 AM
My 2007 bought 2.66ghz Quad Mac Pro is developing a really nasty habit of crashing with no warning in the middle of working, its connected to two monitors via the stock 1900XT card (which I think is maybe the problem). Basically the screens just go blank and the keyboard becomes totally unresponsive, I have to hold down the power button to shut it down.

If I try to restart it generally all the fans kick in at full speed but it wont boot and I have to leave it for about 15 minutes with the power disconnected before I can get it back up.

Frequency of the crashes has gone from rare in the past few months to happening now any time the machine is on for longer that ten or 15 mins,


I have looked in the system logs but cant find anything in there. I can post once the machine is back up (typing this from my MBP).

I am running the machine on SL 10.6.1. Crashes predates SL though.

Is it likely to be the graphics card?

:confused:



fandsw
Sep 26, 2009, 07:39 AM
My bet would be the X1900XT card as well. The one I had was nothing but trouble in my old MP, finally ended up swapping it for a 8800GT. The cooling design on those X1900XT just plain sucks. Take it out of the MP and give it a good cleaning with a can of compressed air.

handheldgames
Sep 26, 2009, 03:29 PM
Make sure your heat sync on the x1900 isn't blocked with dust buildup. Most people don't do routine interior maintenance on their system.

Techhie
Sep 26, 2009, 03:31 PM
If it was a software problem, you would get a panic report when you restarted it. I would double check the RAM, and buy a new GPU to swap out and see if that is the problem. It sounds like you have a dying chip on that graphics card.

Tesselator
Sep 26, 2009, 05:06 PM
Going blank and nothing else works either? That sounds like the PSU. I guess the GPU could be at fault but those symptoms would be incredibly rare.