PDA

View Full Version : Powerbook G4 1.67ghz has poor video playback




Brooklyn8
Sep 27, 2009, 04:06 PM
Hello, I have a 17" Powerbook G4 1.67ghz with the ATI 9700 128mb video card and 1600x1050 screen. I am running Leopard 10.5.8. I love the computer but the video playback on it is terrible. Even youtube videos are choppy. I can watch standard definition video files but not 720p. It there anything I can do or it is just a limitation of the G4 chip and time to upgrade to an intel?

Thanks!



Ruahrc
Sep 27, 2009, 06:50 PM
Hello, I have a 17" Powerbook G4 1.67ghz with the ATI 9700 128mb video card and 1600x1050 screen. I am running Leopard 10.5.8. I love the computer but the video playback on it is terrible. Even youtube videos are choppy. I can watch standard definition video files but not 720p. It there anything I can do or it is just a limitation of the G4 chip and time to upgrade to an intel?

Thanks!

Unfortunately flash video is horrible and I suspect HD youtube flash videos are too much for the G4 1.67. It was too much for my 1.33 G4, and I don't think 300 extra MHz is going to make a difference. It's too bad because it handled 720p quicktime videos just fine :). It was kind of funny at one point when I was using my iPod Touch to watch videos more smoothly than the PBG4. I know the iPT videos are in h.264 format though and although i tried to look for a method to stream those same h.264 videos onto my PBG4 I couldn't find one.

Ruahrc

goMac
Sep 27, 2009, 07:17 PM
Hello, I have a 17" Powerbook G4 1.67ghz with the ATI 9700 128mb video card and 1600x1050 screen. I am running Leopard 10.5.8. I love the computer but the video playback on it is terrible. Even youtube videos are choppy. I can watch standard definition video files but not 720p. It there anything I can do or it is just a limitation of the G4 chip and time to upgrade to an intel?

Thanks!

Eh. A Powerbook G4 should be able to play 720p semi-choppily, enough to be viewable, but it won't be perfect. The G4's design had a lot of issues, including a slow system bus that could cripple the machine no matter what your processor speed was, this could cause issues with video playback...

Brooklyn8
Sep 27, 2009, 09:49 PM
Yea, I figured as much. I'll just probably be upgrading to a refurb macbook pro once I save up enough money. :D

J DILLA
Sep 27, 2009, 10:58 PM
Yea, I figured as much. I'll just probably be upgrading to a refurb macbook pro once I save up enough money. :D
just save a little longer and wait for arrandale.. my pb g4 is gonna have to do until then :D

Super_Saxy
Oct 23, 2009, 07:37 AM
Actually, its not really the G4. I also have the exact same computer that you have, and recently installed Leopard. After searching around a bit on these forums, I found out that the problem is more with Flash 10. Its completely broken for older Macs. I rolled back to Flash 9, and everything works fine! I know have a PowerBook G4 with Leopard running pretty smoothly.

Here's the site with the archived versions of Adobe Flash (http://kb2.adobe.com/cps/142/tn_14266.html)

BarryEngland
Nov 3, 2009, 08:09 PM
I really don't know what the problem is with High Definition (720p and above) on G4 Macs but it seems to be specific to Mac OS X.

MPlayer on MorphOS (an fairly new Amiga-compatible Operating System) running on a 1Ghz G4 can play 720p perfectly without dropping frames (see http://www.youtube.com/watch?v=tvXJk9PSbb8) and even 1080p with the occasional frame drop, while the exact same videos on both my 1.33Ghz G4 Powerbook 17" and 1.5Ghz G4 Powerbook 12" are unwatchable.

Looking around the web, it seems everyone is blaming the G4, which obviously isn't the culprit given that other Operating Systems with that exact same G4 or slower can play HD perfectly. I'd really like to know where the bottlekneck actually is.

cfitz7111
Nov 3, 2009, 10:34 PM
How much RAM do you have. Running 10.5 on a g4 is going to be a struggle to begin with, running video on top of it may be taxing that g4 way to much. Just a thought

autumn
Nov 5, 2009, 12:25 PM
How much RAM do you have. Running 10.5 on a g4 is going to be a struggle to begin with, running video on top of it may be taxing that g4 way to much. Just a thought

I have 1.25GB ram on a 1Ghz powerbook G4 12inch, which I just bought for $135. I installed 10.5.8 on it and the CPU is not taxing at all when I just email or browse the web. Usually just around 10% or so.

But I get choppy video playback on youtube even when viewing SD videos. I don't know why but this laptop is quite capable of doing other basic stuff.

cfitz7111
Nov 5, 2009, 12:36 PM
I had an iMac G4 running 10.4 and it couldn't handle video very well. Video, YouTube, MLB streaming are very taxing on the G4 especially running 10.5, as that iBook is barely over the min specs for 10.5. I think you are asking you machine too much from it.

fta123
Aug 14, 2010, 03:04 PM
Actually, its not really the G4. I also have the exact same computer that you have, and recently installed Leopard. After searching around a bit on these forums, I found out that the problem is more with Flash 10. Its completely broken for older Macs. I rolled back to Flash 9, and everything works fine! I know have a PowerBook G4 with Leopard running pretty smoothly.

Here's the site with the archived versions of Adobe Flash (http://kb2.adobe.com/cps/142/tn_14266.html)

Can anyone tell me how to roll back the flash video to 9, so I can get better quality videos on my G4 Powerbook 17" that I absolutely love ;-)

MacHamster68
Aug 14, 2010, 03:36 PM
go html 5 it works


flashplayer is deliberately made by adobe under apples control to avoid that it works on ppc processors apple wants to sell their intels , apple did try everything to convince people they need intel and snow leopard to use a computer for more then opening a finder , but it did not work tiger is just to good to be replaced by a flashy operating system that has apart from gadgets not more to offer

btw why is everybody so obsessed with youtube watching in HD , there is so much more you can do on a computer , i mean youtube is funny at times ,sometimes even informative ,
but my life does not depend on youtube and i certainly would not trash a otherwise fully working computer in the bin to buy a new intel Mac only to watch youtube on it

victoral.com
Aug 18, 2011, 05:48 PM
I've Had the same problem with youtube till I discovered three "little" things.

The first is ClickToFlash (http://clicktoflash.com/) a free flash blocker for Mac PowerPC and Intel. Update: (Only use this plug-in if you don't intend to use the following.)

Second is TenFourFox (Google code link (http://code.google.com/p/tenfourfox/), Oficial Site (http://www.tenfourfox.com/)), a PowerPC only version of Firefox that only requires Mac OS 10.4, it's really cool because of the incredible speed boost you get for it being optimized for the PowerPC and Velocity Engine. Thats were this next cool thing comes in, HTML5.

HTML5 based video has incredible video playback with standard and even HD videos on very lo spec systems. In fact in conjunction with TenFourFox, HTML5 delivers even greater performance. This because TenFourFox has vectorized HTML5 and HTML5 video! So Web Pages and videos load and play a whole lot faster and smother. Even smother than using H.264! Really!

Now to activate it on youtube just go to the following address www.youtube.com/html5. Youtube is most probably stop using flash anyway, and so are many other websites, so why not be a step ahead? It will be worth it in the end. You'll expand the life of your system two to three fold! So go ahead do it.

Listen... Don't get bogged down by these other people who tell you to go buy a new mac or don't use it for youtube. The fact is that with the right set of programs and optimized performance technology you can get performance that is almost 2 to 3 times better and faster than other computers of a higher spec.

JeffOYB
Oct 2, 2011, 08:37 PM
I've tried a whole buncha tricks and tips mentioned about this problem in Google and none of them have worked. Argh! Spent a buncha hours I don't have to spare. What's up? I don't get it. All these people say these tips'n'tricks have worked, but not for me. What, are computers like people, all different? Whew! It's frustrating.

I have a Powerbook G4 7450 10.5.8 1.5 ghz, 1gb ram.

I've tried so many tricks I can't remember them all. The Optimized Firefox for G4. The TenFourFox. The HTML5. The older Flash version. The Rightclick on vids and Settings changes.

I need to be able to watch nice smooth vid! ...I make them and contribute to various scenes by way of them. But I'm on a low budget. I had a really slow old PPC G4 desktop 10.4. Now I have this PB. Any hope? What's really going on here?

PS: Googling around a bit more I came across the issue of CPU Usage. The Activity Monitor was flashing 100% and about 95% back'n'forth for the User % -- even though I had all programs closed. So I restarted and the % was back down. I started Firefox and it jumped to 30% then I tried an HD video -- and still had no luck and the % jumped to 100%. I tried another old video and IT PLAYED! -- so that was an improvement! ...And the CPU said 85-92%. I then tried an Optimized for G4 Firefox "build" and got same result -- maybe lower %. I tried the TenFourFox with HTML5 and got really staticky, broken-up results -- and 100% usage. I now have Flash 9 installed. I uninstalled Flash 10.1 (or whatever) because of someone's bright idea -- that had no effect on its own. Whew! OK, so now I have the older-format vids back. (From now on when I take vid I'll make sure it's not in HD because I can't check my own stuff on YT.) Anyway, I'm still open to suggestions. ??