PDA

View Full Version : Apple TV Audio Problems




jcschlic
Sep 29, 2009, 12:40 PM
I've owned my 160gb Apple TV ever since it came out, always using HDMI for both video and audio. I don't think I've ever tried using the analog connections, until now.

I recently put together a decent audiophile 2-channel listening set-up and wanted to use the Apple TV's analog audio outputs to hook up to my pre-amp. (while still being able to view the Apple TV's video connection via HDMI to my separate home theater receiver)

I even tried hooking up component to the receiver with stereo audio to my separate pre-amp. No dice.

This is not working for me. What is wrong?



jcschlic
Sep 30, 2009, 09:25 AM
Anyone?

So what I'm essentially asking is this:

Is anyone else able to use HDMI ouput while simultaneously using the analog stereo audio output to a separate receiver/pre-amp?

Alrescha
Sep 30, 2009, 09:50 AM
Anyone?
Is anyone else able to use HDMI ouput while simultaneously using the analog stereo audio output to a separate receiver/pre-amp?

Yes. All the audio outputs are active at the same time.

The exception would be when you have created a movie with only an AC3 audio track, you will not get any audio at the analog outputs.

A.

mchalebk
Sep 30, 2009, 09:58 AM
I have my AppleTV connected to my AVR via HDMI. I also have the analog outputs connected to a separate input on my AVR for audio only playback in Zone 2 (most AVRs will not output digital audio to Zone 2). It works great.

What sources have you tried to play? Have you tried simple audio files or only video? Have you verified that the cables you're using for analog audio work? Have you verified that you've got the 2-channel audio system set up correctly and that it works?

One other thing. I know that Apple has implemented some volume control capability, but I'm not familiar with the details of how this works. I suppose it's possible that the analog audio is muted or turned all the way down.

jcschlic
Sep 30, 2009, 10:27 AM
I have specifically tried this with audio files.

When I realized that HDMI with stereo output to the pre-amp was not working, I tried running component to my receiver and stereo to the separate pre-amp. This didn't work.

I tried as much tinkering with the audio section in the Apple TV as I could without any luck. I even tried different audio cables.

Not sure what to do...I guess I can tinker some more when I get home from work and see if there is something I missed.