PDA

View Full Version : Ram, OWC, and My PB


MBlue
Jul 15, 2004, 11:21 PM
Hey Y'all,


First off I have to give all credit to Other World Computing. I ordered a 1024 mb Samsung Module for my 12" PB Rev. C. At first they didn't have it in stock, so they called me up and asked if I would be willing to substitute.I told them I would be willing to wait and I received the memory soon after.


I receive the ram module and installed it according to the instructions mentioned in the manual. I went to check to see if my PB was reading the memory and the memory was no where to be seen. I figured that I may have installed the memory wrongly and attempted to re-install it. I re-installed the memory four times and received the same response from my PB.

I called OWC and they gladly gave me a RDA # and I shipped it back to them. I receive the replacement module today, installed it according to the instruction given in the PB manual, and my PB still doesn't see it.

I called up OWC's technical support and they gave me a few recommendations to follow. (BTW, they said that the module I sent back passed inspection.) command+opt.+p+r (tried that, that didn't work:(
command+opt.+o+f then typing reset-nvram [enter] set-defaults [enter] reset-all[enter] (still nothing :(

Then I tried a few shots of compressed air in hopes that that would work. Nothing :confused:

So now I come to you, the experts. What do you think I should do? I entertained the thought of trying the module in another laptop, but I don't have access to another laptop. Do you think my ram slot on my PB could be at fault? As I said, OWC has been polite and considerate and I would highly recommend them, but I wish the memory module would work! :rolleyes:
You can view the memory that I bought at www.macsales.com then go to memory, click on "ibooks & All PB", click on Powerbook G4, then check out the memory by "1GB Samsung PC2700 So-Dimm." It's priced at $359.99 BTW does anyone know the "cut & paste" command on Mac? :rolleyes:

Thanks

michael

KingSleaze
Jul 16, 2004, 12:20 AM
Had there been a memory module in that slot previously? Try swapping your current module to other (potentially faulty) slot and new module in currently used slot, see if it gets recognized in both locations. If new module gets recognizedin old slot, you've got a good module. If old module (which does work currently) doesn't get recognized in new slot, the problem would be isolated to the slot. If everything works, great.

MBlue
Jul 16, 2004, 12:37 PM
Thanks for the reply. As for the slot, there was no previous memory module installed and the current module that I have now is soldered inside the PB.

kgarner
Jul 16, 2004, 12:41 PM
BTW does anyone know the "cut & paste" command on Mac? :rolleyes:
command-x is cut
command-v is paste

also
command-c is copy
command-z is undo

MBlue
Jul 16, 2004, 06:07 PM
Thanks for the tip!!

keysersoze
Jul 16, 2004, 07:02 PM
Yes, OWC is great.

Now, about that RAM. Have you tried running your Apple Hardware Test CD? If it says that there IS RAM in the machine, but gives some sort of error, my guess is you haven't pushed it into the slot far enough. It really does take a bit of a push... I had this same issue with my old iBook G4 awhile back. When it's in, it is a VERY snug fit, even at the 45 degree angle, and when it goes down and clips in, hardly any of the gold connectors on the RAM chip are showing (because they are in the slot). If it still is not recognized, the logic board is probably bad. I'd try resetting the ram more firmly into place-- if the logic board is shot it won't make a difference if you push the RAM in too far or too hard. By the way, I went through your same travail-- sent RAM back to OWC and they said it was fine and they sent me the new RAM etc. Good luck!

debo
Jul 16, 2004, 07:28 PM
Should the other RAM be soldered in? That seems weird to me.

solvs
Jul 16, 2004, 07:36 PM
Should the other RAM be soldered in? That seems weird to me.
The 12" PB? Yes. 1 open slot, 1 soldered on.

Have you tried taking it to an Apple Store, or Authorized retailer? Have them check the RAM in other machines? It may be your PB. :(

MBlue
Jul 16, 2004, 09:59 PM
I sure hope that my PB is ok :( I went to an apple store and they said that they would diagnose, but if there is nothing wrong then I would have to pay $50. On the other hand, if there is something wrong they would let me know and send it in for repairs. Did I mention that I really REALLY love my PB 12". My brother asked me if I would trade it in for two 17" PB and I said sure and here's what I would do: give one to you and the other I would sell and buy another 12". No hating to the 17" and 15" crowd but the 12" is something else.


Anyways here is what I did. I was able and my cousin was gracious enough to let me use his laptop ( Sony 14" Vaio) as a testing unit. His computer runs on pc2100 266mhz but my 1GB pc2700 333mhz should work in his laptop regardless, right? WRONG!! It turns out that the computer won't even boot up! I think I found my problem. :) His laptop, I'm sure can support up to 2 GB.( He had two 256mb sticks installed.) Still not really satisfied though. I take the memory from his computer, install it in my PB but it won't work. I didn't really expect is to work anyways. I'm pretty sure that pc2100 266mhz memory modules won't work in laptop's made for pc2700 333mhz memory modules. *edit: found out that they don't* (breathes a slight sigh of relief!)

I'm off to try keysersoze's recommendation(thanks keysersoze!) to jam the module in a little bit harder. BTW solvs thanks for the suggestion of having the mac store put the ram into another PB, but they said that they can't test
3rd party ram into their notebooks. ( trying to get peeps to buy their ram, eh?) Well at least theirs is guaranteed to work......unless my PB is at fault which I'm hoping it's not. ( How could you do this to me?!?! I loved you since the day you came to me. Now you just wanna go and leave and be with some "mac tech support, guy!!!" * in a geeky mockin' tone*

"The Saga Continues"

Ok so I did what keysersoze recommeded, put the ram in firmly, ran the hardware test, both quick and extended versions, everything passed. I check to see if the extra memory is recognized.....nothing. The hardware test said that the logic board passed, I'm thinking that I may have
received a "faulty" memory module from OWC, since it doesn't work in my PB and in my cousin's Vaio. I'm pretty satisfied in thinking that my ram slot is working. If anyone has any suggestions or recommendations, please don't hesistate to post them. It is very much appreciated.

As for me, I'm off to call OWC for a RMA# in hopes that a replacement will prove beneficial.

A thank you goes out to all who contributed to this thread and this forum. Your advice was indespensible in helping me to diagnose this problem.

michael

Sogo
Jul 17, 2004, 12:42 AM
What is the difference between the one that costs 294 and the one that costs 359?

michaelrjohnson
Jul 17, 2004, 11:01 AM
Is the RAM the right density? That got me last summer when I was working with an eMac. Contact OWC and ask.

MBlue
Jul 17, 2004, 03:22 PM
The one that costs $359 ( the one I have) is supposedly the same one that Apple uses in their memory upgrades (Samsung). The other one is a generic memory module.

I called up the tech support at OWC and they said that this memory module is the correct density for my PB.

Thanks for the posts.

michael

MBlue
Jul 29, 2004, 01:19 AM
Hey Y'all,


Just givin' an update on what is up.

First off I love my PB!!! I'm glad I picked this over the bigger versions of the PB.

I went to an apple store. The people over there are really cool; makes me proud to be a macaholic!!! A guy popped in a memory module and all is well. Phew!!! Memory slot is A OK!!!

I'm thinking that the memory from OCW was either bad twice or not compatible with my Rev. C PB 12". Although OCW did say that that particular memory module should work. I'll give them the benefit of the doubt.

As for me, I'm off to buy a 1 GB module from crucial. Hopefully everything will go well. Wish me luck!!!

I would like to thank all the guys and gals who took the time to contribute to this thread.

SolidGun
Jul 29, 2004, 02:06 AM
One from Crucial is around $500 and I sincerely hope that you are going to use some worth while application that needs 1.25 GB RAM. I just read through the thread and I was feeling bad that 512MB stick that I ordered from Crucial worked right away and installation took less than a minute. Hope everything works out for you.
I also enjoy the 12" for its portability and have no need for anything larger.
Keep us up to date on what's going on. :D

MBlue
Aug 9, 2004, 11:10 AM
Ok, so I received a 1GB module from Crucial. I installed it, hoping that my PB will recognize it, nothing. My PB won't recognize it. I am positive that I am installing the module correctly. I'm beginning to wonder whether a 3rd party 1GB module will work on my PB.

I will be returning the module to Crucial and I will be waiting till Apple's prices on memory will go down. Give credit to Crucial as their Customer support is excellent.

Thanks for following this on going saga!!! :p


michael

SolidGun
Aug 9, 2004, 12:04 PM
I didn't have an issue with crucial memory. Their compatibility chart if rather thorough as well as it is convinient. Are you sure that it isn't the slot that is defective? Wouldn't hurt to check.

MBlue
Aug 9, 2004, 01:07 PM
Ya. I'm positive my memory slot is working. I had it tested and checked at the Apple store. They put in a 256mb module in. I don't think there is a problem with 256mb and 512mb modules, but I'm thinking that there has to be something with the 1GB modules from 3rd parties. I may be mistaken though.


Thanks for the help.


michael

michaelrjohnson
Aug 9, 2004, 01:50 PM
Well, according to Apple's Specifications (http://download.info.apple.com/Apple_Support_Area/Manuals/specs/powerbook/L25519A_EN.pdf) for the Rev. A 12' PB, the speed of the RAM it supports is PC 2100 (or 266MHz). You have been attempting to put in PC2700 (or 333MHz) RAM. While this should not be an issue, it may be why you are experiencing trouble. Try purchasing a module *specifically designed* to be used in Rev. A 12' PB.

As another member mentioned, use the "Memory Configurator" whenever purchasing RAM for Apple systems.

MBlue
Aug 11, 2004, 12:10 AM
While that may be true for the Rev. A, I own a Rev. C which requires PC 2700.

Thanks for the thought.

michael