PDA

View Full Version : M$ BT mouse lag prob HELP


cmx08
Jul 16, 2004, 05:47 AM
i could not find the search field in here but I did some google and it happend that some ppl don't have this problem. Is it the mouse or it's normal.

I have the latest updates and use an ext. USB BT key.

pcproff
Jul 16, 2004, 05:57 AM
I have a wireless M$ mouse and it seems like it does perform slower on my powerbook for some reason. But when I use it on my PC it performs just right. That is strange maybe someone on the forum should be able to help us.

d_p
Jul 16, 2004, 06:06 AM
I had the same problem. I changed batteries, made sure all the bluetooth drivers and firmware were the latest version. Nothing helped. I finally gave up and switched back to a USB mouse. Other than the fact that it is almost unusable, it was a great mouse. I'd like to find a fix for it if possible, but I doubt MS will support it.

pcproff
Jul 16, 2004, 06:33 AM
Mine is not bluetooth but it is the wireless hub type, which mouse did you end up getting I was looking at the Logitech mx500

Jo-Kun
Jul 16, 2004, 06:40 AM
mine is unused since its slow... and I need a quick mouse for Photoshop... so I have my old USB one back in use... why it works faster on a PC? maybe because MS provides Windows Drivers on the disk... and the windows mouse Util... I wish they made it for mac so it can be programmed.. and faster...

its maybe a little heavy but its a good mouse if you don't look at the lack of speed... I hope they make software for apple... or I will see no other option than to sell it on eBay...

J