PDA

View Full Version : G5 power PC crash mystery




seligson
Oct 9, 2009, 01:10 PM
My power PC G5 crashes suddenly, and when I try to restart, it will not boot up, crashing again within the first 3 seconds of the startup, just after the apple appears and before the little twirling circle appears. It will recrash as many times as I try to restart. IF I unplug the power cord, and then re-plug it, I hear a couple (?) of clicks and then when I restart, it boots up and works normally, at least for a while.

It may or may not have something to do with a CD drive, since it started happening when Toast failed to recognize blank disks. I also had trouble with the USB jacks, not being able to read external disks and slowing down. All these symptoms go away when I re-plug and restart, until I use the CD drive again (just a theory). I can tell things are deteriorating because the cursor freezes for a spell, before it snaps back. I have also been having separate problems with my internet connection, which may or may not have something to do with it, they seemed to start at the same time. Also, I hear the big "Whooosh" of the fans kicking in at the end of these cursor-freezes.

I recently went to disk repair utility and found lots of permission errors and some errors in the start-up disk. I repaired the permissions, but had to start with another system disk to repair the startup disk, which worked.

However, after the disk utility program gave me a clean bill of health, I tried to restart and, you guessed it, I had to re-plug it in order to get it to start again! Any ideas?

Any info would be greatly appreciated!



opeter
Oct 9, 2009, 01:13 PM
Change your HDD, since it is going to die, soon. Also if you do not have any backups, I think it is time to make.

Dr.Pants
Oct 9, 2009, 01:41 PM
The click after plugin is normal. As for the problems, I honestly don't know what is up - try booting with Cmd-V during its restarting cycle, and see if there's anything in the OpenFirmware boot prompt that would make it go straight to shutdown.

seligson
Oct 10, 2009, 01:55 PM
I will try these suggestions, thanks
Eric

seligson
Oct 17, 2009, 12:54 PM
Still having this problem: If I restart, the computer crashes three seconds into restart, going completely dead. If I restart again, this is repeated. If I unplug and re-plug the power cord, it starts normally and runs fine.

gugucom
Oct 17, 2009, 02:07 PM
Your condition is consistent with a CPU about to die soon. It is known that the PPC970 production process had some issues with the internal metal layers. Statistically these CPU models will have a much shorter life time compared to other Apple CPUs.

If you have a CPU with a maximum of 1.8 GHz your machine will run on one CPU if it is fit to the upper socket. So if you remove a defective CPU it will work on one good CPU in socket A.

For the 2.0 GHz models upwards it is more difficult to diagnose. You need a confirmed good CPU and replace the suspect CPU with it.

Start looking on Ebay for a replacement CPU. Many people sell their PM G5 in parts due to this issue. It is possible to buy replacement CPUs for 50-120$ including the heat sink. But there are also commercial suppliers who take advantage of this situation and ask 600$ for a CPU.

OrangeSVTguy
Oct 18, 2009, 11:09 PM
If you do get a new processor(s), you will have to run a thermal calibration. I have the ASD disc that would do that. Otherwise, the fans will run at full speed.

A side note, have you ever tried just disconnecting the optical drive to see if that could be causing it? Just remove the IDE cable from the logic board. It's connected to the logic board right next to the speaker just under the optical drive.