PDA

View Full Version : Audio n00b... How do I listen to the output of M-Audio Solo with USB speakers?




quantum003
Oct 16, 2009, 11:47 PM
Hi all,

I imagine this has got to be a stupid question... I have an M-Audio Firewire Solo device. I'd like to be able to use it as a mixer- basically I want to send the output of my 300 CD disc changer, and/or my Sirius Radio home docking station through the M-Audio device, into my G5, and then out through my USB speakers. I can get the audio from the M-Audio Solo into the G5 all right... but I can't seem to send the audio to my USB speakers. I feel like I'm missing something. Can someone please enlighten me? Thanks. :)



CalumC
Oct 18, 2009, 02:53 PM
If i understand correctly:

With the interface connected, if you go to system preferences, then sound, you should be able to choose what you use for input and what you use for output. With my alesis firewire i know you can do this, but only for basic apps (logic has to have the same input/output). The other option would be to get a usb-analogue converter, i believe alesis make them for the purpose of getting guitar signal in through usb connection, like a mini interface i guess. That might work in reverse, but don't take my word for it. In fact, thinking about it, the conversion may only be in one direction.

deej999
Oct 19, 2009, 08:15 AM
Hi all,

I imagine this has got to be a stupid question... I have an M-Audio Firewire Solo device. I'd like to be able to use it as a mixer- basically I want to send the output of my 300 CD disc changer, and/or my Sirius Radio home docking station through the M-Audio device, into my G5, and then out through my USB speakers. I can get the audio from the M-Audio Solo into the G5 all right... but I can't seem to send the audio to my USB speakers. I feel like I'm missing something. Can someone please enlighten me? Thanks. :)

So the USB speakers are not connected to the outputs for the M-Audio?

You need to create an aggregate device in AUdio MIDI setup. That combines more than one sound interface. Then you can use the inputs of the M-Audio and the outputs of the USB Speakers.

What are the speakers? So they have a driver or are they class compliant? If they appear as a possible output in the AUdio MIDI setup you can do this easily.

deej

jackerin
Oct 19, 2009, 02:30 PM
You need to create an aggregate device in AUdio MIDI setup. That combines more than one sound interface. Then you can use the inputs of the M-Audio and the outputs of the USB Speakers.
The FW Solo doesn't support aggregate devices afaik.

You could try something like Soundflower and link the FW Solo input to the USB audio.

quantum003
Oct 20, 2009, 01:59 AM
Hi guys, thanks for your posts they were very helpful.

Unfortunately I just could not get the Aggregate Device or Soundflower methods to work for me. I'm not sure Soundflower works with Snow Leopard? I've used it in the past but this time I couldn't even get the Audio Setup dialogue to open.

I just don't know what the heck the problem could be with the Aggregate Device method. I know I'm sending the signal through the M-Audio correctly. My Mac sees the incoming audio just fine. But using the USB speakers as an output just wasn't possible, in any of the many, many ways I tried to do it. "The device has no controls", and it wouldn't make any audio either. So I plugged an RCA stereo set of speakers into the back of the M-Audio device just to be done.

It sucks because the USB speakers are really cool Harmon Kardon Sound Sticks with the subwoofer, they're awesome looking and I wanted to be able to display them in my office. Unfortunately the stereo speakers that work are ugly black Logitech boxes that I hate. Bleh.

jackerin
Oct 20, 2009, 06:26 AM
A more roundabout thing you can do is to open Garageband. There you should be able to set your FW Solo as input and the Soundsticks as output; after that you create a new basic track and turn on monitoring.

(Regarding the aggregate device function, M-Audio says that it is not supported for their Firewire series. Which might be the reason it doesn't work.)