PDA

View Full Version : PowerBook keeps going to sleep - power problem?




Droooooj
Oct 19, 2009, 07:20 AM
My G4 PowerBook (Aluminium 15" 1.67Ghz, A1104) keeps putting itself to sleep at odd times.

This is without a main battery in place, and a dead PRAM battery, both of which I'm waiting to replace.

When I wake it up, it tries to power up, HD spins, but then goes back to sleep without even the screen coming on. I can do this like 5 or 6 times, and then eventually it wakes up and stays awake. For a while.

For the first time today it wouldn't actually even start up from a total shutdown 2 minutes revious. It was just dead. After about the 6th press of the power button it started up.

At first I thought it was a faulty power lead (though the green light on it never flickers on/off to show loss of power). So I've borrowed a mates lead, and although it seems to have reduced the sleeping problem, it's still happening regularly.

Any ideas????



OrangeSVTguy
Oct 19, 2009, 07:58 AM
Usually you should always keep a battery in a laptop as the computer will usually require more power than the power adapter can provide. This is why most of the laptops will downclock itself when a battery isn't present to prevent any shutdown that you are experiencing since they do draw more power during startup/waking.

I'm sure getting a new battery and PRAM battery will help out your problem.

Droooooj
Oct 19, 2009, 08:11 AM
Yeah, I know about keeping the battery in, but it was so dead (crazy impossible readings via Coconut Battery) I took it out to see if it was the battery causing the problem.

With no battery, dead pram and a replacement power cord, I'm now suspecting it might be something flaky internally. :-/

Droooooj
Oct 20, 2009, 12:14 PM
Quick update - shortly after the last post I tried starting the machine up and it just would not switch on. I must've pressed the button 30-40 times, waggling the power lead in case it was loose. I figured the machine was pretty much dead.

This morning I tried it just for luck and it booted up first time! I just can't get my head round it.

I'm wondering if it could be a fault with the DC/Sound board?

Droooooj
Nov 11, 2009, 04:18 AM
Bump with a new question.

I found an old Pram battery and installed that. Started the machine without main battery, set the date, shut it down again, and disconnected the power for 30sec.

Then with AC reconnected it wouldn't switch on again. For about 5 minutes. Eventually I got it to respond and once booted up the date was set back to 1970.

Should the 'new' Pram have retained the date or do I need to reset it or something after installing it?? :confused: