PDA

View Full Version : Powerbook G3 Zip Drive Help




Blair230
Oct 19, 2009, 09:45 AM
Hi! I recently acquired a Powerbook G3 "Wallstreet" with a VST 250 Zip drive module. I am having problems with it. I am running OS 8.6 and have installed the iomega ware for classic on it (I believe the driver is 6.2.3). The drive will power on when I insert the drive. The drive is recognized by the Iomega Tools but will not recognize when a disk is inserted. The drive does not even try to spin up when a disk is inserted. Iomega tools says no disk is inserted. The only way to eject the disk is to put a paperclip in the "emergency eject" hole.

If I leave the disk in the drive and then restart the computer, the drive ejects the disk.

Any ideas?



madog
Oct 19, 2009, 10:17 AM
Sounds like either a bad drive or a bad disk. While I never had a zip drive myself, I heard they were nothing but problems, and the disk life wasn't that good in comparison to floppies.

If it does the same to multiple disks, then it's a good possibility that the drive itself is bad.

Darth.Titan
Oct 19, 2009, 10:21 AM
The Zip drive is kaput. That sounds like precisely the symptoms I had with every Zip drive I ever owned after a couple of months. The drive seems to work, but won't read disks.

Check ebay for a cheap external Zip drive if you have files to recover, otherwise just forget the Zip drive and get a decent flash drive.

Blair230
Oct 19, 2009, 12:02 PM
Thanks all for the replies. Yes that was my thinking too that the drive was bad. I just wondered why the drive didnt even attempt to read the disk, and it could actually eject the disk upon startup.

I have contacted the seller (bought through ebay) and he has an extra zip drive which he will be sending out.