PDA

View Full Version : iMac G5, camera doesnt work but for a sec it DID!!!




candychunk
Oct 24, 2009, 03:08 PM
Hi, I bought this iMac G5 on ebay like half a year ago... the camera never worked when I got it... then today, my sister was telling me to get it fixed... she tried using photobooth... then idk how many times she launched photo booth then the light turned green! it worked... for like a second.. when she moved the monitor, there it is again "the camera-not working icon"... idk if that was a coincident when she moved it then it stopped moving...

any thoughts? what should i do to get it working again? once again, im turning to the helpful mac-expert community :D



MTI
Oct 24, 2009, 09:58 PM
The iMac built in iSight cameras are actually USB devices, with a micro USB plug for the video and a smaller wire harness for the microphone. It could be that yours has either a bad connection, either with the USB plug or the connection to the logic board.

candychunk
Oct 25, 2009, 02:31 AM
The iMac built in iSight cameras are actually USB devices, with a micro USB plug for the video and a smaller wire harness for the microphone. It could be that yours has either a bad connection, either with the USB plug or the connection to the logic board.

do you know if it's easy to access that plug? maybe it's loose? maybe i just need to plug it in all the way... i saw a video on youtube on how to open the mac itself and it looks pretty easy (just some screws), im just worried that it might be hard to access the plug itself and i might mess up something :eek:

rtrt
Oct 25, 2009, 09:39 AM
do you know if it's easy to access that plug? maybe it's loose? maybe i just need to plug it in all the way... i saw a video on youtube on how to open the mac itself and it looks pretty easy (just some screws), im just worried that it might be hard to access the plug itself and i might mess up something :eek:

drop me a pm as i might be able to help