PDA

View Full Version : Suddenly I can't add artwork to albums




ClemTiger0408
Nov 4, 2009, 08:46 PM
I've been doing this for years, so please no step-by-step instructions on how to normally add artwork.

Within in the last 2 or 3 weeks, I suddenly cannot add artwork to entire albums. When I select all then "Get Info" for the entire album, I can edit anything. I can edit the album, artist, song name, etc fields no problem and they all update.

However, when I drop album artwork into the square I've always done it, it won't add. Nothing happens. I drop it and the box stays empty.

Strangely, if I have the artwork viewer open, I can add artwork to individual songs by dragging and dropping into that pane. But I have to do it to every song individually and that's very annoying.

Anyone know why this might be happening? It isn't just one set of files, its ALL my files. But songs previously with artwork retained it with no problem.



jmann
Nov 4, 2009, 08:51 PM
I would do simple permissions check, and then if that works, you can always use a program like CoverScout. I've used it and it works great, but unfortunately it's not free.

yancey47
Nov 4, 2009, 09:19 PM
I noticed this just today. very annoying. one solution is to select all the songs on the album and drag the artwork to the cover area in the lower left corner.

Mugwumper
Nov 5, 2009, 01:18 AM
I've been doing this for years, so please no step-by-step instructions on how to normally add artwork.

Within in the last 2 or 3 weeks, I suddenly cannot add artwork to entire albums. When I select all then "Get Info" for the entire album, I can edit anything. I can edit the album, artist, song name, etc fields no problem and they all update.

However, when I drop album artwork into the square I've always done it, it won't add. Nothing happens. I drop it and the box stays empty.

Strangely, if I have the artwork viewer open, I can add artwork to individual songs by dragging and dropping into that pane. But I have to do it to every song individually and that's very annoying.

Anyone know why this might be happening? It isn't just one set of files, its ALL my files. But songs previously with artwork retained it with no problem.

but it seems to be a function of the individual song. This has happened to
me for a while (2 or 3 versions of iTunes), and the only solutions I've come
up with are:

1. Remove the song from the Library (keep the file, though) and add it to
the Library again (doesn't always allow the artwork to get added, though),
or

2. In iTunes -> Advanced, there is a "Create MP3 Version" option. If your
song has old(er) "Encoded with:" versions or ID3 tags, converting the song
updates everything to the current iTunes levels. Then, you can add the
artwork. If you still can't, then remove the song from the Library and add it
again. For me, this always solves the problem.

Hope this helps . . .

Santa Rosa
Nov 5, 2009, 11:56 AM
Same problem here, noticed it once I had updated to iTunes 9.0.2. Solution at the moment is to save the album art to somewhere on your mac, then in iTunes select all tracks to have the artwork added, in get info double click on the white artwork space then select your artwork file.

I recently did a permissions repair and that didn't solve the problem. Hopefully the next update will fix the problem.

meglet
Nov 5, 2009, 12:55 PM
Same problem here, noticed it once I had updated to iTunes 9.0.2. Solution at the moment is to save the album art to somewhere on your mac, then in iTunes select all tracks to have the artwork added, in get info double click on the white artwork space then select your artwork file.

I recently did a permissions repair and that didn't solve the problem. Hopefully the next update will fix the problem.

Same problem with artwork and 9.0.2 here, as well. I was in the middle of a major artwork cleanup in my library (over the course of a couple weeks) and updated to 9.0.2 in the middle of the project.

Since all of my missing artwork is coming from the internet, it's EXTREMELY annoying that I can't drag straight from Firefox into iTunes now, and have to save the artwork to my local drive, then add it to iTunes from there.

LastZion
Nov 6, 2009, 02:09 PM
Yaup same problem. Can't drag and drop anymore. Its since upgrading I imagine. It works fine if you download to your desktop but who the hell wants to go through that... SUPER ANNOYING!

iMerlin
Nov 10, 2009, 08:14 AM
Same problem here, just noticed it last night and decided to search on the forums here and what do you know... Im not alone!

Im not entirely sure this is an iTunes problem though. Maybe SL?? I used to be able to drag the album art right from Safari to my Photoshop icon on the dock and it would open PS for me so I can crop out the white background from the artwork, not any longer.

So I wonder if its something with Snow Leopard?

Edit: I just updated to 10.6.2 and I can now drag and drop to Photoshop CS3 but still cant drag and drop to iTunes.

NC MacGuy
Nov 10, 2009, 08:24 AM
This still works nicely in 9.02 / 10.6.2 and is super easy:
http://www.liquidx.net/albumartwidget/

LastZion
Nov 10, 2009, 01:06 PM
This still works nicely in 9.02 / 10.6.2 and is super easy:
http://www.liquidx.net/albumartwidget/

Cool thanks I'll check it out

meglet
Nov 10, 2009, 04:43 PM
Same problem here, just noticed it last night and decided to search on the forums here and what do you know... Im not alone!

Im not entirely sure this is an iTunes problem though. Maybe SL?? I used to be able to drag the album art right from Safari to my Photoshop icon on the dock and it would open PS for me so I can crop out the white background from the artwork, not any longer.

So I wonder if its something with Snow Leopard?

Edit: I just updated to 10.6.2 and I can now drag and drop to Photoshop CS3 but still cant drag and drop to iTunes.

It's not a Snow Leopard issue, as I have the same problem on my desktop PC.

Between this and the other issues with 9.0.2, I can't wait for 9.0.3. Then again, with my luck it will be worse!

gbandy
Nov 10, 2009, 04:55 PM
Drag the art to the desktop first and then drag it into the art area of itunes. Works every time for me. Not sure why this is happening now but it only adds one quick step.

LastZion
Nov 13, 2009, 05:38 PM
Drag the art to the desktop first and then drag it into the art area of itunes. Works every time for me. Not sure why this is happening now but it only adds one quick step.

nice one, thanks

Harvey Mears
Nov 17, 2009, 07:05 AM
Same here on desktop with Windows XP and I have been doing this on my old vinyl record collection project for years. Interestingly in cover view the now playing pop-up windows says in grey text "Artwork not Modifiable" and I have not knowingly changed any preferences.

The drag to desktop option did not work for me. The add artwork tab has disappeared from the get info options as well.

What has happened with this version??

Harvey Mears
Nov 19, 2009, 04:13 AM
The upgrade changed the import format in iTunes to WAV. I have now changed it to MP3 and all seems well again

veloceraptor
Nov 19, 2009, 01:51 PM
This happened to me many times on Windows.

Drop the picture in the square, the square will be empty. Just click OK. Artwork will be added anyway. It may not show up at first but if you go to Coverflow, you will see it. Then if you go to the Albums/Artists view, it will be there.

PeteB
Nov 29, 2009, 12:28 PM
This still works nicely in 9.02 / 10.6.2 and is super easy:
http://www.liquidx.net/albumartwidget/

Excellent. I've been unable to update the artwork for an album that I didn't rip/buy through iTunes (I used to own a Zune).

This widget did the trick for me where iTunes just would not allow me to update/drag the artwork.

chandabong
Dec 30, 2009, 10:17 AM
That widget doesn't work for me in 9.0.2 with 10.6.2

reparing permissions doesn't help either

I'm ripping only as wav, I can get artwork for everything available for sale on iTunes fine, have tried many different methods for adding artwork and nothing is working...

jsgreen
Dec 30, 2009, 10:24 AM
I noticed artwork didn't show when dragged to the square, however command-v to paste art into the square seems to work just fine.