PDA

View Full Version : G4 with Leopard 10.5 ....programs terminate




Retrosonic
Nov 12, 2009, 12:15 PM
Guys, hopefully someone can help me here.

I COMPLETLY rebuilt an old G4 Power Mac:

Upgraded the system firmware.

THE problem is that applications like Itunes, Safari, etc, crash, they "Terminate Unexpectedly" after 5 mins or so.

I have removed all PCI cards except the ATI Rage 128 Video card and it still happens.

So.....I have three thoughts:

1) The programs in 10.5 were written to run on Intel, and there is no hope.

2) Some piece of hardware in the G4 is causing the crashing.

3) The Rage 128 is the only original piece of hardware left....could the Rage firmware be causing the problem?

Please tell me your thoughts. I dont have another MAC video card to try.
Is there a way to upgrade the firmware in the Rage 128?
I looked all over the net but could not find any.

Please help if you can!

Many thanks,
Retro



CubeHacker
Nov 12, 2009, 04:53 PM
I was going to ask if you updated the firmware, but you said you did that so...

Its possible that there is an overheating issue with the processor. Is there any way for you to check your temperatures? There have also been some known issues with the G4 upgrades causing crashes. I would search around online for other people with similar issues. Or even better, contact the manufacturer directly as they can usually give good advice.

I don't think the Rage128 would be to blame however. It wouldn't cause applications to crash.

EDIT: Come to think of it, overheating might cause a kernal panic, but probably wouldn't just cause random applications to crash. It might be a memory issue. Does OSX report anything useful when the application crashes?

Retrosonic
Nov 12, 2009, 09:23 PM
Thank you for the reply!

I get the same message every time:

"the application itunes quit unexpectedly. Mac OS and other applications are not affected. Click relaunch to launch the application again"

This is a G4 AGP Graphics Power PC.

Does anyone know the fastest Apple built processor chip I could install in this?

CubeHacker
Nov 13, 2009, 04:32 PM
Depends on the model - sawtooth, DA (digital audio), Quicksilver, or MDD (mirror drive doors).

Since your seems to have a Rage128 i'd say that its probably a Sawtooth or DA, and the max processor it can hold is somewhere in the 500mhz range. We'd need to know the exact model of your system though.

300D
Nov 13, 2009, 05:13 PM
Leopard installation is not supported on machines slower than 866mhz. If you've got a Rage 128 that means the fastest machine you possibly have is 733mhz.

Your machine might support a dual 500 card if it has the right uni-N ASIC. Otherwise, a modified 800mhz card is the fastest Apple-built card that will work.

In any of the above cases, unsupported installation of Leopard itself is likely the root of your problems. Install Tiger.

MacVidCards
Nov 13, 2009, 05:57 PM
You need a real "Core Image" video card.

There is minimal to no support for Rage128.

http://lowendmac.com/osx/leopard/unsupported.html

Buy a PC Radeon 9800 on Ebay for $20-30 and flash it to Mac.

(assuming you have an AGP slot...otherwise a 52/5500 or 6200 PCI might help)

disconap
Nov 14, 2009, 08:35 AM
Yeah, without specs on the machine it's hard to help, the PPC line was broad; the G4 chips alone covered, what, four different models of chipset? Much less Mac mobos and the like...