PDA

View Full Version : Powerbook restarts when idle


AIen
Aug 4, 2004, 05:04 PM
Hi I ust switched from Windows to Mac and so far it's been a great experience. However, I'm having 2 problems that seems to happen consistently and I cant figure out why.

1. Whenever I leave my computer on for the night plugged in to the power supply, the next morning i wake up it is always at the log in screen. I dont know if it just restarted or if it just logged off. But when I logged in none of my application tha I was running before are running when I logged in which leads me to beleive it restarts. I have put hard drive to sleep unchecked as well as restart when there's a power failure thinking it would help the problem but it didn't.

2. Sometimes when I'm typing, the little blanker would randomly pop back to a random place in the beginning of a sentence. Say I'm typing "How are you? I'm good thank you" it would sometimes hop and make me type something like "HoI'm good thank youw are you?" I think it would be because my hand skinned the touchpad causing the cursor to go back.

Any of you guys experienced these problems and would like to comment on it? Your help is much appreciated.

Santiago
Aug 4, 2004, 05:37 PM
Logging out closes all your programs. To find out when was the last time your computer was started, open a terminal window and type uptime.

mac_gal
Aug 4, 2004, 05:48 PM
... 2. Sometimes when I'm typing, the little blanker would randomly pop back to a random place in the beginning of a sentence. Say I'm typing "How are you? I'm good thank you" it would sometimes hop and make me type something like "HoI'm good thank youw are you?" I think it would be because my hand skinned the touchpad causing the cursor to go back.

Yes, exactly right. My PB does this as well.

I don't know if there's a fix, so I just try to keep my hands elevated when typing. Or, I plug in an external mouse. I have my laptop set to ignore all trackpad input when an external mouse is plugged in.

AIen
Aug 4, 2004, 05:48 PM
Logging out closes all your programs. To find out when was the last time your computer was started, open a terminal window and type uptime.

thank you very much, is there a reason my computer logs off when it's idle?

AIen
Aug 4, 2004, 05:50 PM
Yes, exactly right. My PB does this as well.

I don't know if there's a fix, so I just try to keep my hands elevated when typing. Or, I plug in an external mouse. I have my laptop set to ignore all trackpad input when an external mouse is plugged in.

thanks mac_gal, so you don't experience this when you have an external mouse plugged in right?

johncage
Aug 4, 2004, 07:43 PM
If you look in Security under System Preferences, see if the 'log out after xx minutes of activity' box is checked. My Powerbook started doing this once and it confused the daylights out of me until I found that I must have checked that setting at one point. Best of luck!

BTW, this is my first post to Macrumors. Hey. :)

AIen
Aug 4, 2004, 07:56 PM
If you look in Security under System Preferences, see if the 'log out after xx minutes of activity' box is checked. My Powerbook started doing this once and it confused the daylights out of me until I found that I must have checked that setting at one point. Best of luck!

BTW, this is my first post to Macrumors. Hey. :)

Thank you very very much. I believe that just solved my problem. Your first post is a very helpful one, I really appreciate it.

virividox
Aug 4, 2004, 08:26 PM
i once in a while get random switch users; but im thinking i must have hit a key combo no work lost tho luckily enough

mac_gal
Aug 6, 2004, 09:01 PM
thanks mac_gal, so you don't experience this when you have an external mouse plugged in right?

That's right. I've set my computer to ignore all trackpad info if I have an external mouse plugged in. This is a setting, so it won't do that automatically. You can set this at:

Finder > Applications > System Preferences > Keyboard & Mouse > Trackpad

:)

Nspace
Aug 6, 2004, 09:09 PM
You can also get a pref panel called SideTrack (http://www.versiontracker.com/dyn/moreinfo/macosx/20854)

It has a bunch of other handy features that make the mac easier to use without an external mouse.

It is pretty handy and you can set it to ignore the trackpad while you are typing. That also may solve your problems.