PDA

View Full Version : Behringer UMX61 MIDI Controller on Garageband?




andyschwander
Dec 5, 2009, 10:09 PM
I just got a Behringer UMX61 MIDI controller, having been told it was "plug and play" on a Mac. When I open Garageband, it recognizes that a MIDI device is connected (I'm connecting via USB) but it's not selectable on the input menu. It won't make any sound as is, so obviously something needs to be done.

I looked for drivers, but there aren't any for OS X (so much for Mac-compatible).

Has anyone used this particular controller? Am I just missing a step or do I have to return the darn thing?



pkoch1
Dec 5, 2009, 10:34 PM
I just got a Behringer UMX61 MIDI controller, having been told it was "plug and play" on a Mac. When I open Garageband, it recognizes that a MIDI device is connected (I'm connecting via USB) but it's not selectable on the input menu. It won't make any sound as is, so obviously something needs to be done.

I looked for drivers, but there aren't any for OS X (so much for Mac-compatible).

Has anyone used this particular controller? Am I just missing a step or do I have to return the darn thing?

In Garageband, you don't set up a MIDI controller as an input like you would an audio interface. The fact that it doesn't need drivers means that it's class-compliant and the drivers are built into the OS.

Check what it says under MIDI status under Audio/MIDI in your GB preferences. Does it say that there are MIDI inputs detected? (Is that what you mean when you say that it is recognized?)

Can you play the instrument if you use Musical Typing? (CMD-Shift-K)?

andyschwander
Dec 5, 2009, 11:34 PM
Yes, sorry that's what I meant...it says "1 MIDI input detected", so I know Garageband is reading it.

I can play the software instrument with musical typing or the on-screen keyboard, but the controller doesn't do anything whether I have those open or not. I've checked the buttons on the controller to make sure I don't have a mute button pressed or something, but it looks to be fine.

Any ideas? Thanks for the help!

dzamo
Jan 2, 2010, 11:03 AM
Yes, sorry that's what I meant...it says "1 MIDI input detected", so I know Garageband is reading it.

I can play the software instrument with musical typing or the on-screen keyboard, but the controller doesn't do anything whether I have those open or not. I've checked the buttons on the controller to make sure I don't have a mute button pressed or something, but it looks to be fine.

Any ideas? Thanks for the help!

I just bought a Behringer UMX61 and connected it to my iMac 10,1 via USB. It just worked for me in GarageBand - I didn't have to do any configuration. A screenshot of my GarageBand prefs:

http://lh3.ggpht.com/_F4QPE590kWA/Sz97md2COUI/AAAAAAAACOw/whbocqP5iaQ/GarageBandPrefs.jpg

ChrisA
Jan 2, 2010, 11:47 AM
Yes, sorry that's what I meant...it says "1 MIDI input detected", so I know Garageband is reading it.

I can play the software instrument with musical typing or the on-screen keyboard, but the controller doesn't do anything whether I have those open or not. I've checked the buttons on the controller to make sure I don't have a mute button pressed or something, but it looks to be fine.

Any ideas? Thanks for the help!

I really dislike USB MIDI. I always use equipment that has those round DIM plugs then I connect to a MIDI<->USB interface. The advantage is that I can see the LEDs on the interface. They blink when data pass. This makes debugging a setup so much easier because I can see if midi data is being sent.