PDA

View Full Version : 2g: no wifi after upgrade to 3.0




bobdobbs
Dec 10, 2009, 07:38 AM
Hi all.

I used redsnow to upgrade two 2G iphones to 3.0.

One of them now has no wifi.
It has no wifi symbol on the springboard.
If I go to settings->network, it will not pick up my wifi network.

Under settings->general->network, it shows that it does have a MAC address. And it shows 'unavailable' under network.

I have not tested it yet for edge connectivity.

I googled this problem, and found an apple support page.
I went through all the steps, but none worked: resetting the network, resetting all settings and wiping the phone, even replacing the firmware again.

After googling around, I've reached the conclusion that this was a common problem with this update.

Does anyone know if there is a solution to this ?

I found one forum post somewhere that says that one fellow solved this by downgrading all the way to 1.1.4, then using iliberty+ with a wifi fix payload, and then upgrading again.

Does anyone know why this would work ?