PDA

View Full Version : Imac G5 iSight issues




Kelpy
Jan 3, 2010, 08:48 PM
Hello,
I know this is probably a common thread but i've tried researching everywhere and this is my last ditch attempt at my macs salvation.
I have an Imac G5 iSight that was working fine until my power supply went out. It was out of warranty so I went to the local mac/pc store and had it replaced. Now when I plug it in it will act like its starting up but all I get is the glowing spot that comes on when the computer is asleep blaring at full power and fans powering on and then quieting down and charging back up but nothing comes up on the screen.
I've reset the pram and it came back on for a short while but it would freeze whenever I tried to do anything more than move my cursor around the screen. I've started it from the disk and fresh installed the os. Now even when I reset the pram nothing happens. I opened the case to see if it was maybe the bulging capacitors but every single one was A-Okay which was frustrating after I went through all the trouble of prying off the cover and lcd screen.
I am pretty much at my wits end and was just wondering if there was anything else I should check before I huck this thing in the trash and start scraping and saving my extra cents for a new desk top, almost makes me want to go back to PC, at least when they break down it's not a 1k+ investment.
Thanks,
Kelly



tomacintosh
Jan 3, 2010, 08:54 PM
So basically you paid for it to be repaired, and they didn't repair it?

I'd be straight back to that shop if I were you.

Kelpy
Jan 3, 2010, 10:04 PM
Its been a year or so since I've had the power supply replaced, I've tried to deal with them but all they told me was that they could re-diagnose it which didnt sound appealing since it cost them 80+ dollars to diagnose it in the first place. I've had it sitting since I'd given up hope but a friend got it to start for a short while recently with the pram restart which made me decide to take it apart and look and see if it had the capacitor issue, which it doesnt appear to, no leaking and everythings got a flat top.
I figure I'll give it one last shot to fix and if that doesnt work I'll huck it in the garbage bin.