PDA

View Full Version : small problem loading music to i tunes library




donnie666
Jan 7, 2010, 10:45 PM
so i just got a mac, trying to learn how to use it. so far so good BUT.....
im having trouble loading a few albums into my itunes library. i have hundreds of albums and they all loaded just fine but 2 albums in particular will not load/play/or be recognized at all in itunes. ive checked the tags and the file format. when i choose file>add to library>select album>CLICK OPEN...NOTHING HAPPENS. the window just closes and itunes hasnt added the album. it doesnt even inform me if something is incompatible. ive tried dragging the files but still nothing. the ironic thing is that i actually paid money for both these albums, they were exclusive mp3 releases from one of my fav record labels. out of all the music i have, these two albums should be the most legitimate. maybe some one else has had a similar experience.



kfordham281
Jan 7, 2010, 11:23 PM
Do they have DRM? From your description it sounds like DRM or the audio format is not compatible with iTunes.

donnie666
Jan 7, 2010, 11:46 PM
well if i had DRM on the files, wouldn't that restrict me from copying the files over in the first place. i originally downloaded the music on my pc. i copied them and put them on my mac no prob. and they will load onto a zune just fine.

Lorenz0
Jan 8, 2010, 01:51 AM
Could be an iTunes-unfriendly format like WMA.

I lost a good half dozen or so albums when I switched to mac

Cinematographer
Jan 8, 2010, 02:04 AM
Well if I had DRM on the files, wouldn't that restrict me from copying the files over in the first place?

DRM'd AAC files e.g. can be copied, but not played.