PDA

View Full Version : Connecting to Windows 2008 VPN Server using L2TP over IPSec




mikes63737
Jan 12, 2010, 05:29 PM
I just set up a VPN server on my Windows server box. It's working perfectly when I try to connect using PPTP on my Mac, iPhone, and Windows laptop, and when I try to use PPTP or L2TP over IPSec on my Windows laptop.

But I can't connect to it using my Mac or iPhone and L2TP. Since it's working with my PC laptop, I'm thinking that there's an incorrect setting on my Mac or on the server. Does the Mac require any specific settings, or should the default settings work, and something is just broken?

I'm running 10.6.2, fully updated, and Windows Server Enterprise 2008 x64, fully updated. The PC laptop is running a fresh install of Vista Home Edition (no updates).



mbestel
Jan 19, 2010, 12:10 AM
Hi,

I recall there is an issue where Mac OS X does not use the standard port (1701) for L2TP connections over IPSec but instead uses a random port.

This has caused me problems when connecting to non Apple VPN servers in the past.

This was all quite a while ago though, so I can't be sure if this is the reason for your particular problem.

Cheers,

Mark

mikes63737
Jan 21, 2010, 11:09 AM
That's interesting.... do you know how to force it to use that port? That way I can see for sure.

I'm thinking it has to be something like that, because the Windows machine connects just fine, but the Mac doesn't even show up in the log as a failed authentication attempt.

mikes63737
Jan 30, 2010, 01:08 PM
Bump

mbestel
Jan 31, 2010, 06:43 AM
Sorry, have been away.

I never managed to force the Mac to use port 1701.

I played around with modifying the VPN configs (racoon, etc.) but didn't work it out.

Ended up throwing away the linux vpn server I was using and going with either OS X Server or a Draytek modem/router that I had laying around.

Cheers,

Mark