PDA

View Full Version : powerbook won't run without battery




tubescent
Jan 21, 2010, 05:26 AM
bought a second hand powerbook - seemed ok.
now i find it won't seem to run off the mains ac power lead unless a battery is installed. is this normal?
also it came with 2 batteries and the machine will only power up with one of the batteries installed - with the other it's just dead whether the power lead is connected or not.
to make this clear:
- won't power up on just mains lead (no battery)
- won't power up with one of the batteries
- will power up and charge with the other battery

is this normal or should i be looking to return the item?
worried
mike



techound1
Jan 21, 2010, 01:14 PM
Not normal - return it. You probably have a problem with the little board (depending on your model, there may be a board or it may be a direct connect to the mobo, if memory serves) that holds the pins that connect to the battery. Sometimes swapping the board out will take care of it; if not, its a problem on the mobo where the battery board connects to it.

willpower101
Apr 18, 2010, 01:04 PM
Not normal - return it. You probably have a problem with the little board (depending on your model, there may be a board or it may be a direct connect to the mobo, if memory serves) that holds the pins that connect to the battery. Sometimes swapping the board out will take care of it; if not, its a problem on the mobo where the battery board connects to it.


Can I ask you why, if the powerbook will not boot without a battery, it would have anything to do with the connections from the battery to the motherboard? I have several open in front of me right now and I'm trying to troubleshoot the same problem.

Are powerbooks supposed to boot without the battery installed? None of these do and either I really have 3 bad mobos or that's some kind of normal behavior?