PDA

View Full Version : Macbook Air won't connect to any wireless network




Goldcard
Feb 1, 2010, 07:03 PM
My macbook air has stopped connect to wireless internet while in Mac OSX. When I switch over to Windows or use any other computer I can connect just fine. I've tried two different networks and can't seem to connect on either. Does anyone have any ideas? Would re-installing safari from a zip drive or some other drivers work? Any help would be greatly appreciated.



nj-mac-user
Feb 1, 2010, 07:11 PM
My macbook air has stopped connect to wireless internet while in Mac OSX. When I switch over to Windows or use any other computer I can connect just fine. I've tried two different networks and can't seem to connect on either. Does anyone have any ideas? Would re-installing safari from a zip drive or some other drivers work? Any help would be greatly appreciated.

Is any type of encryption enabled on your wireless router? Is it actually connecting but you're simply unable to browse via Safari or is it not even connecting to a network period? If the latter, it wouldn't have anything to do with Safari.

Goldcard
Feb 1, 2010, 08:50 PM
I don't think it has anything to do with my router because when I am on windows (on my macbook air via boot camp) I can connect fine. My other computer connects fine as well. It has something to do with my Mac OSX connecting to routers. Doesn't seem to matter what router it is. Does that help narrow it at all?

The wireless does show to be connected but it always says "self assigned IP". I think this might be the problem? The IP setting is at DHCP but when I click renew it always comes back with same IP number. Thoughts?

stoconnell
Feb 1, 2010, 09:00 PM
Have you cleared all of the saved network connections? There have been several threads on this in this forum.

It could also be a permission issue. Have you tried running the repair permissions from Disk Utility or creating a new user and trying to connect?

calderone
Feb 1, 2010, 09:05 PM
There has to be IP addresses available on the DHCP server.

I would start with trashing or moving:

/Library/Preferences/SystemConfiguration/com.apple.airport.preferences.plist

Reboot.

If that doesn't work try:

/Library/Preferences/SystemConfiguration/NetworkInterfaces.plist

One of these should solve your problem.

Goldcard
Feb 1, 2010, 10:01 PM
Have you cleared all of the saved network connections? There have been several threads on this in this forum.

It could also be a permission issue. Have you tried running the repair permissions from Disk Utility or creating a new user and trying to connect?

How do I clear the saved network connections? Do I just delete my saved wireless networks or is there something more to it? Sorry for the repeat threads but when you search "wireless not working" you get quite a few results haha.

Goldcard
Feb 1, 2010, 10:02 PM
There has to be IP addresses available on the DHCP server.

I would start with trashing or moving:

/Library/Preferences/SystemConfiguration/com.apple.airport.preferences.plist

Reboot.

If that doesn't work try:

/Library/Preferences/SystemConfiguration/NetworkInterfaces.plist

One of these should solve your problem.

Dragged these both to the desktop and then to the trash and they re-created themselves upon restart. Neither seemed to fix my problem. :( Thanks for the advice.

calderone
Feb 1, 2010, 10:35 PM
One more to try is:

/Library/Preferences/SystemConfiguration/com.apple.network.identification.plist

stoconnell
Feb 1, 2010, 11:00 PM
How do I clear the saved network connections? Do I just delete my saved wireless networks or is there something more to it? Sorry for the repeat threads but when you search "wireless not working" you get quite a few results haha.

Network -> Advanced -> Airport

then select and delete (-) any from the "Preferred Networks". You could also try making sure your home network is at the top.

Goldcard
Feb 1, 2010, 11:02 PM
One more to try is:

/Library/Preferences/SystemConfiguration/com.apple.network.identification.plist

This combined with deleting the networks from my saved wireless network connections seemed to do the trick! Thanks so much for your help!!!!