PDA

View Full Version : G5 Quad won't boot




Grandier
Feb 3, 2010, 11:42 AM
After not using my G5 Quad for a few days, when I tried turning it on it just wouldn't start. The red light goes on once, and I hear some noises from the disk drive and so on, but no chime. I get nothing on the screen, and in a few seconds the fans go on full blast. There is also apparently no power going to the keyboard, as the cap locks light won't go on.

I've tried everything that I could think of, or that I found on the forums:

-Disconnecting everything
-Unplugging it for a few minutes and trying again
-Taking out the RAM and starting computer with just 2 modules
-Reseting the SMU button inside
-Starting up from a DVD

Nothing has worked so far. At this point it seems that my only option is to take it to the apple dealer, but I really don't trust the repair people in my country (I'm not in the US), as I've had some bad experiences with them in the past, plus I am flat broke right now and cannot afford to pay for the repairs.

Does anybody have any idea what could be causing this problem, or what I could do to try to fix it?

Thanks.

H



666sheep
Feb 3, 2010, 12:18 PM
Check diagnostic LEDs on logic board first: http://support.apple.com/kb/HT2652 If any of them will not light up, then it may be a faulty graphic card (i had similar issue in client's 2.3 DC last days). If you don't have any Mac PPC PCIe card at hand, you may use any PC PCIe graphics.
If your Mac will chime and start loading OS with PC card plugged in (with no video of course) - BINGO! - you need new card.
Of course it may be infamous coolant leak = damaged lobo, cpus and others, but that what i wrote is easy to do and it may resolve your problem.