PDA

View Full Version : Xserve RAID Problem


173080
Aug 25, 2004, 11:37 AM
Yesterday I came across a weird problem on my Xserve's RAID Array. It's a RAID 1 (Mirroring) Array, which I created using the included Disk Utility. The problem is that under Server Monitor and Disk Utility my array is listed as "Degraded", and with a warning. I noticed that it was running only off one of the drives, so I'm guessing this is a real problem. How can I fix this?

I'm pretty confident that the drive is just being left out of the array in a weird way, I'm almost sure it's not a hardware problem. I have a lot of configuration done on this Server, so reinstalling everything is not an option. It would take me days to configure everything the way it should be.

I am almost sure the cause of this problem is because someone accidentally pulled the plug on the Xserve, so the RAID Array links might have been corrupted.

I also can't afford to have this server down for more than a few hours.

Something I was looking at is using Carbon Copy Cloner to clone the volume from the drive that remains onto my FireWire800 external HDD, then recreate the array from the Panther Server Installation Disc, and then cloning the data back to the array. Would this work?

Any ideas?

tomf87
Aug 25, 2004, 11:50 AM
If you truly think it is software and not hardware, simply break the mirror and re-mirror it. Most of the RAID applications I have used won't erase data, and I assume the XServe is the same way. If it did erase data during a re-mirror, it wouldn't do much good if a drive failed.

tomf87
Aug 25, 2004, 11:57 AM
<Repeat post deleted> My apologies...

MacsRgr8
Aug 25, 2004, 04:40 PM
Since Mac OS X 10.3 repair Mirror works excellently using the Disk Utility on the Mac OS X 10.3 (Server) CD!

Just boot from the CD, and try the Disk Utility.
Select the RAID, and let Disk Utility guide you what to do.

If you're using Mac OS X 10.2.x then stuff gets a little more complicated:
You must go into terminal.

Use the command "diskutil"
Just type this command, and see the usages.
Always do a "diskutil checkRAID: first! Make sure which drive is in which bay.... remember that the HFS+ volume is "seen" as the RAID volume itself.
Once you have verified all data, do "diskutil repairMirror" (example: "diskutil repairMirror disk3 2 disk1 disk2"), and compair your RAID volume ("disk3"). and your drives 1 & 2 (from which to which?)

What also will work (if you can throw the server offline for some time) is to create an DiskCopy image of the RAID Volume.
You can create a DiskCopy image (.dmg) of the volume easiest by booting from a FireWire Disk, and using DiskUtility to create the image from that Volume.
When done, make a new Mirror-set, and simply restore (10.3 only) the image to your new RAID.

Good luck!