PDA

View Full Version : ID3 tags getting stripped




theHBD
Feb 6, 2010, 11:14 PM
Having trouble keeping the info of my songs intact after they are sent up to my website for download.

Using iTunes, I am converting the files from AAC to MP3, making sure all the info (title, name, album name) is present before uploading to my site. However, when I do a trial download, my name and album title is missing. The only thing that shows is the name of the song and it looks like this: 01-Just-a-Girl-1.

I asked my host provider and they said the problem is on my end with the ID3 tags. I have tried everything I can think of but for some reason, the info is getting stripped when it leaves my computer. How do I fix this?

More... Or go to the site and see for yourself, (thehbd.com). just choose 0.00 for the price and download a couple of tracks.

I went to see a Mac Genius at the mall. He's heard of the problem but didn't have any answers other than researching it myself. Which is what brought me here. Perhaps if I used a PC to upload the tracks?


I think I managed to fix the problem on my own, (which is good because I think I stumped everyone). Basically, I deleted all the tracks, reimported them into my iTunes, converted them to mp3's, checked all the info and put the latest ID3 tags on them (V2.4?), and sent them on their way to my website. From the tests I've been doing, I think all the info is sticking to the track. Let me know if you try it and it works/doesn't work for you. Cheers!