PDA

View Full Version : iBook G4 skips grey Apple/spinning clock screen




Thanksarthur
Feb 8, 2010, 09:41 PM
I have an iBook G4 (Late 2004) that I just recently upgraded to Leopard using the 10.5.6 DVD included in the Mac Box Set. Whenever it boots, after the chime the screen stays black until the login screen. This happened occasionally with Tiger, but I found a post somewhere where someone suggested to hold the power button while powering on until you hear a beep. That solved it in Tiger, but I have not once seen a grey Apple screen in Leopard.

I forgot to mention that I have reset the PRAM and PMU.



chrismacguy
Feb 9, 2010, 12:04 PM
Hmmm, sounds like youve just got a slightly dodgy Leopard Install (I have the same thing happen to me on my PowerBook G4 15" 1.67Ghz under 10.5.8 - but its never bothered me or done anything weird, so I havent bothered fixing it :) )

MacTech68
Feb 9, 2010, 12:53 PM
Try resetting display settings (http://docs.info.apple.com/article.html?path=Mac/10.5/en/8807.html).

Try resetting NVRAM. Boot the computer and immediately hold the Apple, Option, O, F keys. You should then see text on the screen. Release the keys and follow steps 1-4 in this article (http://support.apple.com/kb/TS1812?viewlocale=en_US).

Try resetting the PMU (http://support.apple.com/kb/HT1431#faq6).

If you have a video adapter plugged in, remove it before trying the above.
________
ipod games (http://macgame.org)

Thanksarthur
Feb 10, 2010, 12:03 AM
Tried all of those, no difference yet. I'm now attempting to reinstall leopard and see if it helps.

Thanksarthur
Feb 10, 2010, 12:52 AM
Leo reinstall did nothing. Is there anything else I could possibly do? I know it's not critical but it's very unsettling to me.

MacTech68
Feb 10, 2010, 04:40 AM
Leo reinstall did nothing. Is there anything else I could possibly do? I know it's not critical but it's very unsettling to me.

I should say that since the iBook isn't running any OS display drivers initially, that it would seem that either the back-light isn't energized at power-on or it's out-putting a display resolution that the internal display can't handle.

Your previous fix seems to indicate an NVRAM display setting is stuck.

It's possible that a display preference in your user's home directory or /Library/Preferences/ is corrupted and keeps setting the default display to a setting the iBook can't use on boot-up. Once the display drivers load, it over-rides the setting.

Look in /Users/YOUR_USERNAME/Library/Preferences/ByHost/

and move any file beginning with com.apple.windowserver..........plist to the trash.

Look in /Library/Preferences/

and move any file beginning with com.apple.windowserver..........plist to the trash.

Now reboot.

When you used the Command-Option-O-F on boot-up, did you see text on the screen?

Try these commands in Open Firmware: (note the added "set-defaults")

reset-nvram
set-defaults
reset-all

Once you get to the login window, choose "shutdown" (if available) and reboot.

Can't guarantee any of these will fix it. Just going down the path I would go. I don't think it's a huge problem. Just a query, have you ever used "Screen Spanning Doctor" to setup an external display without mirroring?
________
Toyota Racing Development history (http://www.toyota-wiki.com/wiki/Toyota_Racing_Development)

Thanksarthur
Feb 11, 2010, 07:31 AM
tried all of the suggestions, still nothing. no text when booting with open firmware, just had to input the commands on a dark screen. it did reset after i typed "reset-all" though. I have never used Screen Spanning Doctor or any other similar utility.

Kim Philby
Feb 11, 2010, 01:38 PM
http://en.wikipedia.org/wiki/Mac_OS_X_Leopard

"... Leopard drops official support for slower G4 and all G3 processors.[51]"
"... This is due to the lack of AltiVec in the G3 line of processors and the fact that most pre G4 and early G4 systems do not have video hardware capable of supporting Core Image, two technologies Leopard relies heavily upon among others. Leopard can be "hacked" (see below) to install on these G3 and pre 867mhz G4 machines but the system may behave erratically and many of the programs, features and functions may not work properly or at all."

NewMacbookPlz
Feb 11, 2010, 02:54 PM
http://en.wikipedia.org/wiki/Mac_OS_X_Leopard

"... Leopard drops official support for slower G4 and all G3 processors.[51]"
"... This is due to the lack of AltiVec in the G3 line of processors and the fact that most pre G4 and early G4 systems do not have video hardware capable of supporting Core Image, two technologies Leopard relies heavily upon among others. Leopard can be "hacked" (see below) to install on these G3 and pre 867mhz G4 machines but the system may behave erratically and many of the programs, features and functions may not work properly or at all."

The late 2004 model (as OP listed) will have a 1.2-1.4ghz G4 chip depending on screen size, so that's not the issue as 867mhz was the minimum CPU speed for a straight 10.5 installation.

Thanksarthur
Feb 11, 2010, 08:51 PM
Correct. Mine is the 14" 1.33/1.25GB model so I don't believe it's a hardware issue.